Bug Report - Wenatchee 5 Build 2014-01-28 - Load Problem

I do not use SaveSmall either.

Ok, I tested TestSingleWindowModeling and quit, relaunched and opened a file…
I get hard crashes now. On one of these I got the file report with McNeel dialog so I did and included your name in it Marlin so you can associate it with this thread.

How do I go back to single window?

Also with TestSingleWindowModeling enabled, if I open 2 windows and then close one of them, it stays open but no longer accepts input and is “hung”.

do this:

How to reset Rhino’s preferences

the new default is single window so that should do the trick.

(but i’m more curious to see if it gets rid of the other problems you’re having as well)


Before you delete your Rhino preferences file, please zip the file and email a copy to me.

I’m having the same problem everyone else is once I loaded the new build. There is not rhyme or reason to it. I can’t seem to open any of my older files. I get the same initial window everyone else is getting and the wheels spin but nothing ever happens.


I got your model, and it does not hang for me. Something else is causing this.

Please post your OpenGL settings. I still don’t know anything about your hardware or software environment.

I looked at your crash, and Rhino is crashing when the mouse is moved and a viewport is not completely initialized. Now this should not happen, and I’ll look into why this is happening, but it makes me think of another test.

Copy one of your models to one of the corners of your desktop, then double-click the model. Rhino will open the file, and your mouse will never, ever, be over the Rhino window while it loads. Does it still crash? Does it still hang? It’s a crazy test, but I don’t have good ideas at this point.

Marlin, sent the preferences file.

I also reset the preferences from the terminal as described above and so far I’ve opened and closed 15 files with no “hangs”. However, now that I am aware of a potential issue I’ve noticed a very obvious hesitation right during the loading/drawing of the model - the point where I took the screenshot above.

I have already moved back to single window so I am not able to test the crash until I switch back. I’ll try to test that tonight and report back.

Hardware/OS is: OSX 10.9.1 - 2.9GHz, intel core i5, 32 GB RAM, Fusion drive.

Here are my Open GL:

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-01-28 (498)
OS X version: Version 10.9.1 (Build 13B42)


Hardware information

Computer hardware
Hardware model: iMac13,2
Processor: Intel Core i5-3470S CPU @ 2.90GHz
Memory: 32 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GTX 660M 512 MB
Memory: 512 MB
Screen size: 2560 x 1440
Displays: iMac

USB devices
UltiMachine (ultimachine.com): RAMBo
Western Digital: My Book 1140
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: iPhone
Logitech: Logitech Wireless Headset
3Dconnexion: SpaceNavigator
Kingston: FCR-HS219/1 Mobile Reader
American Power Conversion: Back-UPS RS 1000 FW:7.g4 .D USB FW:g4
Apple Inc.: FaceTime HD Camera (Built-in)

Bluetooth devices
Apple: Apple Magic Mouse
Apple: Apple Wireless Keyboard

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.18.22 310.40.05f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

So I’ve opened and closed well over 50 files now with no load issues. However, I have 1 file that I created in this version yesterday that will not respond to a few degrees of motion on my 3DConnecion space mouse! It won’t rotate for instance. It was fine earlier today - prior to resetting. Is this a setting for the model?

sorry for jumping in here during the debugging process… i’ll be doing some onsite drawings starting tomorrow and i just wanted to make sure i had some outs in case i experience any of this stuff… the terminal reset appears to have worked for michael so i’ll quit worrying about it… hopefully he was able to retain enough helpful info prior to resetting.

i’ll shut up now. :smile:

Interesting, that window/file that won’t let me use all the axis on my space mouse has a message in the status bar in lower left corner of window:

Creating meshes… press escape to exit - see screenshot

It’s been there for over 20 minutes. And yes, I did press escape and nothing happens. This might be a bit of smoking gun?

Closing and reopening the file has the same result - that message does not go away and my space mouse is not completely functional.

@Michael_Hackney got your preferences file and I can duplicate the hang when loading your model, so it is likely something unexpected in your preferences that is causing Rhino to hang. Now to start digging and finding the problem.

Perhaps you are too close to the camera focal point. Try the ZEA command to reset your viewports. Did that help?

Yes, its a smoking gun. Rhino doesn’t erase that message once meshing is completed.

ZEA clears the message but does not fix the space mouse issue. To be specific, my space mouse only translates in X, Y and Z but will not pan, tilt or rotate this file! All of my other files work properly.

Also, after issuing the ZEA, I close the window, quite Rhino and relaunch an open that file - I get the creating meshes message and no rotations.

Back “in the day” I was the lead on developing a big application on Motif on XWindows on Dec Ultrix. We did a beta in CA at a field office (telephone company) and one of the women there could get our software to crash 100% reproducibly. We were in MA and tried everything with her on the phone. She described what she was doing in detail and we could never reproduce. So, I finally flew to CA to literally watch her and hopefully see something.

I sat down, she launched the application, turned to me to say something and as she did she pushed the mouse cursor to the upper right corner of the screen - CRASH. The issue was a Motif problem that at 0,0 (which was the upper right corner for some odd reason) it caused the Xserver to crash.

Once I figured out that this was the problem, the fix was “don’t do that!”


did you name the viewport ‘Parallel’?

you might have some weird viewport/cplane settings which are causing the behavior in this particular file…

maybe the easiest ‘fix’ for it would be to copy the geometry from the weird file and paste it into a fresh window.

I didn’t name it parallel but yet, there it is, Parallel! How do I change it back? When I right click to get the context menu, select viewport options and change to perspective, nothing seems to happen

i don’t know… on my way out now so i don’t have time to look into it… i’d copy/paste into a fresh window though then resave… that should sort it out.

Interesting, when I do a View->Set View and change to perspective, the space mouse now works but the viewport is still called Parallel.