Bug In Bad objects Imported from Sketchup file

import
bug
sketchup

#1

I Imported a Sketchup file into RhinoWIP for mac as trimmed planes

exploded the blockinstance

bad object was created

was shown

when I SelbadObjects , the following occurred.

The “SelBadObjects” command created 1 bad objects.
Command: SelBadObjects
No objects added to selection.

I try to turn off automatic checking but it keeps showing the warning message…

I am not sure whether there is any problems in the bad objects or the sketchup file.

Defu-Singapore-SJ-Cabinet.3dm (3.1 MB)


#2

I also have this happen from time to time on various import operations, also on the Windows side… Don’t know if there are some automatic fixing routines being run in the background, or if the bad object report is just spurious…

–Mitch


#3

had this myself recently, the only way I found to turn this off was to shut rhino down and then re-open


#4

yes it solves!!


#5

I has never happend to me onWindows - but on the Mac all the time. Anoying bug!

Yep, that’s the only solution.
I hope for a quick fix…

Philip


(Pascal Golay) #6

Hi Li - can you post the skp file, or send it to tech@mcneel.com? We’ll take a look.

-Pascal


#7

For what I see on my iMac, all file types that are bad objects, and that activate the automatic control before the WHIP 5E41w NOT allow you to turn off the automatic verification.


#8

Defu-Singapore-SJ-Cabinet copy.skp.zip (485.4 KB)


#9

may I know what are low objects?


#10

Wrong translation. I meant bad object


(Dan Belcher) #11

Hi @li1-

I see this behavior. I’ve logged the issue in MR-3079. In the meantime, you can do one of two things:

  • Use Rhino 5.3.2 (which does not exhibit this behavior)
  • Use the latest RhinoWIP (5E63w).
  • In the RhinoWIP, run -CheckNewObjects and disable the check and then restart the RhinoWIP. The setting should stick.

We’ll look into fixing this in 5.4.

Best,
-Dan


(Dan Belcher) #12

This bug should be fixed in the latest RhinoWIP (5E63w). Please give it a try.

IMPORTANT: The workaround that I presented above was ill-advised. This set a permanent flag. If you used this workaround, you will not get new notifications of bad objects ever until you run CheckNewObjects again and check the enabled box and restart Rhino. You will now receive new bad object warnings but you can ignore them for that particular modeling session.