Invalid geometry window (urgent) WIP Build 5E41w


#1

MacOS Sierra 10.12.3
I can not turn off the automatic verification of objects.
In this case, the copy paste to a new file does not help me because I have absolute need to save or export the named views.

  1. if you simply rotate it an “invalid” object appears the dialog box.
  2. if I select the option “disable automatic checking” this has no effect.

automatic control in progress
Automatic checking is disabled for this modeling session.
Run the command “CheckNewObjects” to disable the check for all future sessions.

invalid geometry entered into the model. When that happens, usually it’s not serious errors but can cause problems in future operations.
The Rhino development team want to fix this bug.
To report this bug, click report bugs.

Choose from the following options.

turn off the automatic verification
continue with the automatic verification

Report bugs continues

I solved as well (but probably with ReadViewportsFromFile command would be equal)


Bug In Bad objects Imported from Sketchup file
Rhino 5 for Mac WIP Build 5E63w
#2

Version?


#3

I updated. forgives.


#4

The “CheckNewObjects” verification NOT can be disabled ( Files created before the 5E41w had activated the “CheckNewObjects”) . It is unthinkable to do all the steps I described all my files. Every time you try to make changes appear the two windows that I published.
@dan


#5

Yeah, this is really annoying - and not the way the windows version works. Needs a quick fix. That windows keep popping up even if the bad object is fixed. You have to close the file and re-open to get rid of that… persistent window…

Philip


#7

In the presence of bad object, still you can not disable the “CheckNewObjects” function. A little information about it please let.


#8

+1 [on the request for info.
same problem here,
A few bad objects are hidden somewhere in the file [like old leftovers] but which has no disturbing roll in the relevant model. meaning i can safely ignore them, and don’t need to deal with trying to fix/replace them.
But now this massage [like in Simon’s case] totally makes the file unworkable now.


#9

@dan, @marlin

Philip


(Dan Belcher) #10

I see this behavior. I’ve logged the issue in MR-3079. In the meantime, you can do one of two things:

  • Use Rhino 5.3.2 (which does not exhibit this behavior)
  • Use the latest RhinoWIP (5E63w).
  • In the RhinoWIP, run -CheckNewObjects and disable the check and then restart the RhinoWIP. The setting should stick.

We’ll look into fixing this in 5.4.

Best,
-Dan


#11

Tanks @dan, this worked for me.

«Randy


(Dan Belcher) #12

This bug should be fixed in the latest RhinoWIP (5E63w). Please give it a try.

IMPORTANT: The workaround that I presented above was ill-advised. This set a permanent flag. If you used this workaround, you will not get new notifications of bad objects ever until you run CheckNewObjects again and check the enabled box and restart Rhino. You will now receive new bad object warnings but you can ignore them for that particular modeling session.

CC: @rhinorudi, @Akash, @Zsimon, @Philip, @ec2638


#13

Doing it right now, thanks.