"Check new objects" window is popping up after every command


I am having trouble with the “Check new objects” window popping up after every command. If I switch it off, as told in the dialogue box this problem continues. Very annoying.

1 Like

I have the same issue. And it’s after EVERY command - even changing the viewport render mode so VERY frustrating. It’s especially prevalent when I’ve imported a .STEP or .IGS.
On occasion it can be rectified by saving out the original file to native .3DM but it’s still an annoying bug that I had never seen in the previous version.

Is there a bad object somewhere in the file? If you do a SelBadObjects does something actually show up? If you eliminate it (them) does the dialog go away?


There may have been a bad object but the bug is the fact that “turnoff automatic checking” has no effect.

Well, I was just trying to ascertain if it was coming up up every time because there is a bad object somewhere - which Windows Rhino will also do - or if it was coming up even if there are no bad objects in the file.

Just for the sake of having tried everything, does running the following macro turn it off?

-_CheckNewObjects _Check=_No _Enter

If so, it’s the UI that is at fault, if not the bug is deeper in the code…

I will try that next time i encounter the issue. My thought is though that if I have to use a macro to turn off an option that the warning supposedly allows me to do, it is then a deeper problem whether or not the macro sorts it out - does that make sense?

It’s certainly a problem that needs to be fixed. I am just doing some “investigative journalism” to see at what level the problem might be. It might be simply that the command works, but the button you push in the dialog isn’t hooked up correctly. That would be the case if the macro actually works. If the macro doesn’t work either, then the problem is further down towards the core in the layers of software…


1 Like

I’m working on simple things just now so not sure if I’ll incur the wrath of the ‘bad objects bug’ but I’l report back when it next occurs, thanks for you advice.

This seems like a similar symptom: SetDisplayMode command creates bad objects.

Yes. It seems to be the same problem. I verified with a very simple model with no bad objects.

(I wrote “SetDisplayMode command creates bad objects”)

I’m still unable to reproduce this behavior on my end. Can you please provide a file and simple steps to reproduce this one? (For some users, a full Quit and Restart of Rhino solved this issue).

Hi I have the same problem and unable to use software. is there any updates?

Unfortunately, we are not able to reproduce this reliably on our computers. Can you provide a 3dm file and steps to reproduce this behavior? Also, adding your System Information (Rhinoceros > About Rhinoceros > More info… > Copy to clipboard) helps us as well.


same here.

This happens always to me at files imported as step with option join surfaces (written from catia). To solve this in my case, I’ve to delete the block definitions. (First explode block, next delete the block definition in block manager.) Then the “checking popup window” was never seen again at my files.

Just to make sure, before you delete all block definitions, does the window also pop up for commands like e.g. Length or any of the zoom commands?
Can you post a simple STEP file that causes this behavior on your system?

Yes - I think every command (not changes to the view with the mouse) does have the effect to the popup window. I’ll ask for permission to send you a file or a screen video.

File and video is uploaded.

Seconded. The worst part here in my opinion is that pop-up, which gives you the option to switch checking off, but keeps coming back.

Yeah, that’s annoying.


I also have this issue. I can’t use Rhino like this. Please let me know if we have a solution or if I can help in any way.