Blocks a new but very old and irritating topic

Working in Rhino 7 now and it looks like some problems have been fixed but others remain. Trying to edit a block This pops up, and pops up and pops up.
image
Which is very familiar :rage: I click on the ok and the edit session never appears and this pops up
.

Also block export does not auto populate the file name when only one block is selected but will automatically name the blocks if a group is exported. Version 5 named the file in either single export instance or in a group instanc.

Is something being done to fix the block issue. V5 worked fine, No need to comment on V6 if you use blocks. Please fix this, It may not be that big of an issue for some work, but my work often includes 100’s of blocks and block management is essential

Below is an example of 100’s of blocks, its a poured urethane line that that exists and making parts now. The next one is going to be larger / longer but uses everything in the last one. Making any change to this is difficult in V7 but not in V5 other then V5 video doesn’t like it but thats what Box in box display is for…

Categorized.
Please assign your new messages to the appropriate category so the right people are more likely to see it.

Thanks

And what category would that be

It looks like John assigned this thread to the Rhino Rhino for Windows category.

Still trying to work with Rhino 7. Started a new session, clean slate nothing in the model, Imported a block, linked and embedded and then tried to do a block edit. It crashed but did not give the block conflict popup. That block was an assembly of several blocks.

I then opened another session imported a simple cube shape, linked and embedded, tried to do a block edit by double clicking on, popup came up that is supposed to and then it crashed and sent another sad Rhino with a smashed beach ball. Does block edit and import work or not. Is it just my Rhino and computer or is this a problem for others. I can be importing and linking from the desktop and it still throws the same error

This is the simple cube shape located on the desktop that caused the last error when imported, linked and embedded, and then double clicked to edit

Can you post the .3dm file for this along with instructions on how to crash Rhino. I think you will get much faster response if you do this.

I know next to nothing about working with blocks so I need your. 3dm file and instructions to try reproducing this on computer. If it does not crash then you will have 1 new piece of information.

Regards,
Terry.

Hi - In addition to what Terry wrote, are you sending in the crash reports? I am not seeing any when I check the eMail address that you have here on Discourse.
-wim

Im sending every report, This is the model that crashed 2/19 sometime this morning. It would be last one I sent today. (Correction I sent some more this afternoon) block 1.3dm (182.4 KB)

This is the simplest example of what is generating a crash. This little detail exists on my desktop and it still can not be double clicked and worked on in block edit. It causes a crash. The larger model shown is way to big to post.

The first attached file is the block in this file block experiment.3dm (223.5 KB)

And waiting and waiting and POOF

Thanks for the file and the additional screenshots. That procedure doesn’t crash on my end.
Could you please run the Rhino SystemInfo command and copy-paste the result here?
-wim

Rhino 7 SR3 2021-2-8 (Rhino 7, 7.3.21039.11201, Git hash:master @ 7bcc02a54515376cb2bd3d05f62d9473ab4bc38c)
License type: Commercial, build 2021-02-08
License details: Stand-Alone

Windows 10.0.18363 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [97% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P4000 (NVidia) Memory: 8GB, Driver date: 12-6-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.66
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1

Secondary graphics devices.
Intel® HD Graphics P630 (Intel) Memory: 1GB, Driver date: 12-10-2018 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-6-2019
Driver Version: 26.21.14.4166
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 6\Plug-ins\RhinoCAM 2020 for R6\RhinoCAM 2020 For Rhino6.0.rhp “RhinoCAM 2020 - The cutting edge CAM plug-in for Rhino 6.0 from MecSoft Corporation”
C:\Program Files\Rhino 6\Plug-ins\RhinoCAM 2020 for R6\RhinoArt1FileExporter For Rhino6.0.rhp “RhinoArt1FileExporter”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\BlockEdit.rhp “BlockEdit” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Thanks. Have you tried disabling the plug-ins that do not ship with Rhino?
-wim

@wim I edited a post a few posts back, I left out the actually file that crashed and posted the block itself. The first file was the block, The edited addition has that block in the file

block experiment.3dm (223.5 KB) block 1.3dm (182.4 KB)

No…My Rhino 5 has more added plugins then either Rhino 6 or Rhino 7. And of course Rhino 5 block features work fine.

Ill reset the plugins and have IT wipe and do a new install to see if that helps. I think in Rhino 7 all that was added was BoltGen, and the latest Rhino Cam

that’s old…

Its probably new as far as MY IT dept is concerned :grinning: But they update often

Ill see if they will update it, If they wont at least I can blame them for some of this :rofl:

fyi: most of crashes people report here are fixed with a driver update.

Well im at the mercy of a corp IT dept. They are pretty responsive and automatic updates happen regularly. Not sure why this would not be updated since anything that is Rhino, network, or video related is looked at right away in my group. I just put a ticket in to update the driver.

Do you have issues with editing blocks in Rhino 7?

not (yet) any new ones, I won’t to elaborate on outstanding issues, lot’s of threads already about that

if I double click a linked embedded block, I just get the popup that allows me to open the file in a new instance (works as expected) or edit the block in file to break the link (works as expected)

Hi -

That doesn’t necessarily mean anything. Rhino 5 is quite a ways away from Rhino 7. Please try with the 3rd party plug-ins blocked.
-wim