Block in the A** HASSLE

This matter of Rhino importing hundreds of blocks and nested blocks when one inserts a DWG or Step file is a major hassle and time eater. I tried to install a plugin called ExlodetoLayers but that’s only for the Windows versions. Even after exploding and deleting every last bit of the imported file I still get an error!!

This is an unwanted adventure and second rate performance for such a mature application.

Shared with CloudApp

It’s a WTF issue, don’t you think?

Shared with CloudApp

Qutting the application and restarting doesn’t solve the issue.
Running the explode blocks command is also useless.
Shared with CloudApp

I moved your message to the Rhino for Mac category.
Please categorize your future posts.
It keeps the forum tidy and makes sure your questions are seen but the right group of people.

Thanks

Thanks John,
It was easy to get to the correct forum until the recent upgrade. Now when I choose the drop down help menu/Rhino for Mac Support Forum I get an error notice/page

Shared with CloudApp

SO I click on the graphic on the upper left

Shared with CloudApp

Then I arrive at this

Shared with CloudApp

Then look for the proper forum

Shared with CloudApp
Shared with CloudApp

There’s no Rhino Mac to be found.
Shared with CloudApp

Looking further doesn’t help.

I pointed out this issue a while back but there’s still no improvement. Maybe it was posted in the wrong forum … funny!

Not

Right.
Thanks. Still there’s the other aspect.

Since Rhino issues are generally the same for Windows and Mac as of V6, there is a Rhino category, and “Rhino for Windows” and “Rhino for Mac” subcategories:

image

Apparently the Mac Version hasn’t been informed.

I’ve made a smaller version of the model to upload and another issue comes up (again) that’s when presented with the file upload dialog - it doesn’t respond.

Shared with CloudApp

I can drag the file in but it’s just another irritating issue with the interface. Is there some browser plugin that may be causing this?Support.3dm (5.7 MB)

Hello - ExplodeBlock on the incoming STP stuff and then Purge > BlockDefinitions = Yes, should help.

-Pascal

Shared with CloudApp

Hello, please just run the Purge command and make sure BlockDefinitions=Yes.

-Pascal

Thank you. That worked. Is there a more efficient process to avoid such chores when importing non rhino files?

Hi -

The Windows version wasn’t informed either.
On the list as RH-62295: Help: Menu links to Discourse fail
-wim

:+1: