Black dots all over meshes in rendered view mode

Hi everyone,

I’m having problems taking just a simple snapshots out of my rhino model. I have Rhino 7 for mac.

When switching to rendered view mode, almost all the surfaces are covered with black dots! I’ve tried toggling the settings of rendered view mode (shadows, objects) and also with file settings render quality, switching sun or skylight on/off… Nothing has helped so far! Also found this previous chat about a similar topic but things suggested there didn’t work for me.

Here’s how it shows on my screen and on the captures I take.

Can anyone suggest something to try? Any help appreciated! :slight_smile:

Hello - is your scene very far from the world origin? What do the camera coordinates look like? (In the Properties panel, with no selection)?


Hello Pascal,

Actually yes, it was. Simple thing that slipped from my mind at the start of the modeling! Now I set the origo close to the model.

And when it comes to the camera coordinates, this it what I get:

  • Veera
  1. Turn on everything in the model
  2. Select everything
  3. Move everything close to 0,0
  4. Run ClearAllMeshes
  5. Go back into your working display mode

Any luck?

Hmmh, I tried that but my computer doesn’t wanna do it before rhino crashes… The file is 85 Mt in size and has lots of background information on it. I know it’s too big, but for this study I haven’t got the time to sort every file out…

Thanks for the good advice, it’s too bad I didn’t have a chance to get it fixed now. Next time I’ll be more careful when starting a new file. This I’ll try to figure out somehow in post production phase!

Please run the Rhino “SystemInfo” command and post the results.
This sill give us a good overview of the computer resources Rhino sees and may suggest a change.

Hi John,

This is what I got from that command:

Rhino 7 SR5 2021-4-10 (Rhino 7, 7.5.21100.03002, Git hash:master @ 2cd158094b595f6400479d7cbe511454b6149527)
License type: Educational, build 2021-04-10
License details: Cloud Zoo

Apple Intel 64-bit macOS Version 10.14.6 (Build 18G5033) (Physical RAM: 16Gb)
Mac Model Identifier: MacBookPro11,4
Language: fi-FI (MacOS default)

Intel Iris Pro OpenGL Engine (OpenGL ver:4.1 INTEL-12.10.19)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1536 MB
Graphics: Intel Iris Pro
Displays: Color LCD (221dpi 2x)

Graphics processors
Intel Iris Pro (1536 MB)
Color LCD (1440 x 900)

USB devices
Apple Inc.: Apple Internal Keyboard / Trackpad
Broadcom Corp.: Bluetooth USB Host Controller
Logitech: USB Receiver

Bluetooth devices

Third party kernel extensions

Third party plugins

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino “Snapshots” 7.5.21100.1002
/Applications/Rhino “PanelingTools” 7.5.21100.1002
/Applications/Rhino “Renderer Development Kit” 7.5.21100.1002
/Applications/Rhino “Displacement” 7.5.21100.1002
/Applications/Rhino “Legacy Rhino Render” 7.5.21100.1002
/Applications/Rhino “Commands” 7.5.21100.3002
/Applications/Rhino “Import_OBJ” 7.5.21100.3002
/Applications/Rhino “export_xaml” 7.5.21100.3002
/Applications/Rhino “QuadRemesh” 7.5.21100.3002
/Applications/Rhino “export_OBJ” 7.5.21100.3002
/Applications/Rhino “RDK_EtoUI” 7.5.21100.3002
/Applications/Rhino “Export SVG” 7.5.21100.3002
/Applications/Rhino “MeshCommands” 7.5.21100.3002
/Applications/Rhino “Export_DAE” 7.5.21100.3002
/Applications/Rhino “PDF Export” 7.5.21100.3002
/Applications/Rhino “IGES Export Plug-in” 7.5.21100.3002
/Applications/Rhino “Import_SVG” 7.5.21100.3002
/Applications/Rhino “BlockEdit” 7.5.21100.3002
/Applications/Rhino “Export_AMF” 7.5.21100.3002
/Applications/Rhino “Rhino Render” 7.5.21100.3002
/Applications/Rhino “Import_DST” 7.5.21100.3002
/Applications/Rhino “PLY - Polygon File Format Export” 7.5.21100.3002
/Applications/Rhino “Import_AMF” 7.5.21100.3002
/Applications/Rhino “RhinoCycles” 7.5.21100.3002
/Applications/Rhino “IronPython” 7.5.21100.3002
/Applications/Rhino “Grasshopper” 7.5.21100.3002

Hello- if possible, update to a more recent Mac OS version and see how that works.