Rhino 6 'Rendered Mode' is Black

Hi everyone,

For one of my models, whenever I change my view to ‘Rendered Mode’ my screen goes black. Does anyone know how to fix this problem? This only happens with one of the models, I’d say the heaviest one!

Thank you all!


Generally and black viewport indicates a problem with OpenGL graphics.
It could be old drivers or maybe something about that file is overrunning the VRAM on the graphics card and triggering an error.

Make sure your Mac is up to date with updates from Apple.
Is it an old Mac?
What MacOS are you running?

Maybe run the SystemInfo command in Rhino V6 and post the results.


Hi John!

Thank you for your response, heres what it says when I run the SystemInfo in Rhino V6.
It’s a new mac and is up to date! It’s macOS Catalina Version 10.15.4

Thanks again!!

Screen Shot 2020-05-04 at 10.53.41 AM|493x500

I don’t see anything obvious there, but because you used a screenshot, it’s very hard to read, even on my 27" monitor.
Next time please copy/paste the text.

How many monitors are you running and at what resolution?
If you run SelBadObjects does anythins highlight?

Hello @John_Brock , I am having the same issue just now, I don’t think I have ever experienced this.
I just updated my laptop and I even open other files and rendered view works just fine.

I did the SelBadObjects command that you recommended in the previous post and there isnt anything.

It starts showing once I uncheck the Flat Shading box, so I guess I can keep working with this settings.

Any idea what would be the cause and solution of it? Thanks

Sorry, that description is too vague to repeat.
Can you repeat this?
If so, can you please send your file and those specific instructions to follow?

Then I can try it here and if I can repeat it, I can get it on the pile to be fixed.


Sorry about that,
I meant I am having the same issue, meaning that my “Rendered mode is [also] black” and I think this is the first time I experience this ever.

  • My Macbook Pro is up to date.
  • I ran the ‘SelBadObjects’ suggestion you made in the comment before mine but nothing got highlighted.
  • I was able to see it rendered only when I unchecked ‘Flat Shading’ on the Rendered View Settings.
  • I don’t experience this with other files or even when I export simple geometry out of this file.


NODE.3dm (3.6 MB)

I was able to repeat this in V6 but not in V7.
Thanks for the help!


A post was split to a new topic: Black in Rendered display mode

A post was merged into an existing topic: Black in Rendered display mode