Rhino 7 - BLACK screen in Rendered View

Hi,

I just installed Rhino 7 and created a simple box. When I try to view this in Rendered view, it turns black. I was trying to decide whether or not I need to upgrade, but this is a bit concerning after using it for 30 seconds. Hope somebody can help.

I’m running Windows 10 with an i7-8700k cpu @3.7 GHz, with 32 GB ram

I looked at a few of these other posts, and I did update my graphics card NVIDIA Quadro P4000 to the latest one.

Thanks,

Alvin

What does your render tab look like? I don’t see any lights or any environment indicated in your scene.

you also may want to go to tools>options>view>display modes>rendered and reset to defaults.

1 Like

Thanks for the quick reply Kyle!

I went into the render tab and turned on everything. Still black.

I didnt see an option to reset to defaults, although I’m literally using Rhino 7 for the first time so I didnt change anything.

I turned on the Cycles Option and it seems to show up now. But wow, I hope this doesn’t need to be on every time I use rendered view. Its dragging and all I have is a small box. :worried:

something is not right here…I’m thinking rhino is not seeing your graphics card

please run the systeminfo command in rhino and paste the result here-

Also go to tools>options>plugins and make sure the render rdk is loaded.

Are all these loaded?

If you are still stuck call us at tech support-

Technical support (206) 545-6877

Yep, those are on.

Here’s the system info:

Rhino 7 SR1 2020-12-8 (Rhino 7, 7.1.20343.09491, Git hash:master @ 350b20978b4fcd75493212fbd3c4248983612f86)
License type: Evaluation, build 2020-12-08
License details: Stand-Alone
Expires on: 2021-03-11

Windows 10.0.19041 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P4000 (NVidia) Memory: 8GB, Driver date: 10-22-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 452.57
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

Secondary graphics devices.
Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-24-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-22-2020
Driver Version: 27.21.14.5257
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Did you manage to create a Windows Control Panel > Power options > “High performance” power setting option?

Is there a solution to this issue?

yes,
it’s typically a graphic card issue, you need new drivers (clean install) and you need to make sure all monitors are plugged into the video card, and not the motherboard monitor port.

post your systeminfo results from rhino for more specific help.

I tried almost everything at this point. here’s the system info.

Rhino 7 SR4 2021-2-16 (Rhino 7, 7.4.21047.11001, Git hash:master @ fcf2374e901bd5fefe6baacfa9d0554aff427bac)
License type: Evaluation, build 2021-02-16
License details: Stand-Alone
Expires on: 2021-05-18

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 1-8-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1
Primary OpenGL: NVIDIA GeForce GTX 1050 Ti (NVidia) Memory: 4GB, Driver date: 1-22-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.40
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-22-2021
Driver Version: 27.21.14.6140
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.4.21047.11001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.4.21047.11001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.4.21047.11001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.4.21047.11001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.4.21047.11001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

if you disconnect your external monitor does it work?

Also your gtx card had a game ready driver and a studio driver… try the studio driver with a clean install (choose advanced, or custom when you install the driver and check the clean install option)

I really need to get this fix as soon as possible. I have so much work to get done, but no other helpful contacts.

call us- (206) 545-6877
we are closed for lunch until 1pm pst but are here till 5pm pst

sorted via phone call-

fwiw folks, if you are struggling with something that is preventing you from getting your work done- please call or email us directly at tech-

the fix here was to change the nvidia settings, reset the rendered view to defaults and reset the rendering panel to defaults.

3 Likes

Hey Chris,

So is your problem the same issue I was having above, where your rendered screen was black?

Try changing Anti-Alias from 8X to 2X.

That seemed for work for me. It was when I was trying to use anything above 2x that it was black.

Alvin

Fixed over the phone. Kyle was a life saver! Just call them (206) 545-6877 if anyone else is having this issue.

Very Thankful!

Fixed over the phone. Kyle was a life saver! Just call them (206) 545-6877 if anyone else is having this issue.

if in the UK, what is the equivalent number to ring, as ringing USA, unless they are on whatsApp, is financially a killer, £10,…£20,…£30 ramps up in tens of minutes, and the MB shuts off as a ceiling of £10 is set.
Have they WhatsApp ?

Steve

call our barcelona office, they handle all the europe support.

That fixed the issue for me as well.

Hi everybody,
I am having a similar issue with the black viewport, however, whenever it happens it is for all of the viewpoerts at once, even if I open another session. I adjusted the computer power use and gave Rhino performance preference on the graphic card. I changed “antialising” for 2X too. That solved the problem, however once in a while I had the same problem again. I could go around it by Restarting Rhino or Restarting the computer when Rhino only wasn’t enough. Now this is happening quite often (3 times each morning or afternoon). That is really time consuming nowadays, having to connect to VPN, get a ZooLicense and so on. I would like to fix it once and for all.

Anybody has an Idea of what else could be done that I haven’t done yet?

Thanks, Felipe