Will a large file kill render view?

I’ve been designing an exercise model and have been switching between Wireframe, Shaded and Rendered. It had been working fine. However, suddenly, when I switch to Render, and my screen goes black. All other display modes work including Raytrace. I just checked, and the model has grown to 775,000 KB. Could the size of the model be the problem?

Pics are Shade Mode and a few seconds of raytrace Raytrace mode, and Rendered mode

Rhino 6 SR21 2019-11-20 (Rhino 6, 6.21.19324.04391, Git hash:master @ 3565e17ca9274d7ab98d6b3a100e28814ed37bef)
License type: Commercial, build 2019-11-20
License details: Cloud Zoo. In use by: CalypsoArt ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: FRAGBOXNOTE

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce RTX 2070 with Max-Q Design (NVidia) Memory: 8GB, Driver date: 9-5-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 436.30

Secondary graphics devices.
Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 12-10-2018 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-5-2019
Driver Version: 26.21.14.3630
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.21.19324.4391
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\ClippingBox (4dfff1df-5f09-43ae-a044-77b115244b02)\1.0.0.0\Rhino 6\ClippingBox.rhp “ClippingBox” 1.0.0.0
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.21.19324.4391
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.21.19324.4391
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\RealDrawings (9aaa3b93-9ea4-4425-b44e-8a8c4500c274)\1.0.7038.31206\RealDrawings.rhp “RealDrawings” 1.0.7038.31206
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.21.19324.4391
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.21.19324.4391
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\BlockEdit.rhp “BlockEdit” 6.21.19324.4391
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Users\Calyp\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2019.7.29.584\SectionTools.rhp “SectionTools”

There’s a chance that if you don’t pester it for a minute or so, so that it can do its thing. It may render, though doing something like rotating the display often may or may not be fraught with laggyness, depending on things.

Keeping the mesh sizes/resolution small may help.
Keeping the textures small may help.
Keeping the passes/cycles/rays or whathaveyou set low may help.
Lowering the antialiasing may help set up the scene.
Also, Anisotropic filtering is costly, so, unless you are shooting vanishing-point perspective shots with fancy textures, you can make sure it’s low, like 2x.

I’ve found that the Cycles’s interactivity becomes poor with large scenes. AFAIK, At some point, with Cycles GPU rendering, things are sent in batches to the GPU. If the batches are small, the interactivity is good but the render-time is long. If the batches are large then the interactivity becomes poor.

There is an adjustment for this in Cycles, but I wish it adjusted more.

Though, IMHO, you can indeed save some pretty big renders to a file, though the interactivity requires patience, or Rhino will lock, and will often white-out just before you are one extra event from locking it.

Lastly, the MaxQ versions of nVidia GPU’s–even the ones I am looking at in Thinkpads–can only use a lower DTP than a desktop computer version. Your GPU likely takes less than 90 watts, whereas a desktop version of a 1070 likely takes 150 watts.

Some things that cannot preview on GPU can for some reason render on CPU, though it’s slow.

That stated, Cycles can do some nice renders. For some of these, I positioned and changed things, and then switched to rendered to check, and then did the final capture to file thing.

The biggest thing, so far I did was:

More here:

1 Like

Thanks for the reply. The problem is very strange. All other modes including Retraced display. In rendered mode it’s just black immediately. CPU usage varies between 0.0 and 1.0% and memory use at 2397mb. I’ve let it run for over 30 minutes and nothing but black screen.

Hi - can you post that file?
-wim

Oddly, did you try to switch to CPU? If there isn’t enough memory on the GPU, the CPU may work. I needed to do that for a render or two.

Hi @CalypsoArt (and @Brenda)
From what I understand, it’s the “ordinary” rendered mode (not Raytraced) that isn’t working, right? A shot in the dark: Have you a) tested for bad objects? and b) tried with a smaller viewport size (4 viewports), switching to rendered and (if it works) maximize the rendered viewport? It’s not a solution, but might help in finding out what’s wrong. Oh, and also c) check for new drivers for both cards, although they look fairly up-to-date. And finally d) try resetting your rendered display mode to default, to make sure that it’s not some setting that got screwed.
HTH, Jakob

Can I post a file the 820,000+ KB?

I did not try. Would the memory on the 20270 not be enough for rendered when it is enough for Raytraced?

Correct

How do I check for bad objects? Would this only affect Rendered mode?
Will see about the viewport, but the same question, what not other modes?
The machine is set to automatically update drivers.
Rendered mode works with other models, and in fact, parts of this one that I modeled separately and imported into this file.

you can use _SelBadObjects and yes, some Bad objects lead to bad meshing that doesn’t show properly in render

Thanks. Found two bad objects. Deleted, saved the model, then render mode. Still black.

and using RefreshShade after that?

Hi @CalypsoArt
As for the drivers, it’s not always a good idea to trust those automatic updaters, but you might be right. You could try to copy/paste the model into a new file and see if that makes a difference. Or you could hide all the parts, at showselected a few items at a time, to see if it’s a specific object or a specific number of objects that turns the screen black.
If all else fails, you could upload it to McNeel for the pro’s to have a look (or here, if you’re willing to share the model).
HTH, Jakob

New information. If I isolate individual objects, render mode works with them. It just does not work with the whole model. I did the refresh and render worked for about 2 seconds and then it went black again. The model is there as elements can be selected. (gumball shows) It’s just that the the model elements and background is black.

I still question the driver as the problem as it is not evident with other Rhino modes or software (AutoCAD, Corel, etc) What might be a problem is changes to the render mode settings. I need to record any changes before I reset and see it that does any thing. I’d expect McNeel would want to know if it was a result of a setting change.

I expect the McNeel crew is off for the holiday weekend, and I can continue without Render mode. I’ll wait to see if they have any thoughts next week, then I’ll post the model here. I’m not sure what the size limit is? What does “Save Small” actually do to the model to make it small?

two more ideas:

  • what if all the objects are converted to meshes
  • I forgot the second
  • ah yes, using dynamic display under the visualization options to avoid calculating the view while rotating the camera. it will only show it when still.

I feel that the rendered viewport should get a little attention.

Ok, so I reset Rendered to defaults and now it works. That is so odd. To reiterate. If I selected a couple model objects/blocks and hid the rest, it rendered fine. Try to render the whole model and I got a black screen. After resetting to Render defaults, the mode works for both situations. Prior to resetting, I did try changing things like “ambient color” but nothing worked. Pics are the new render image and the previous altered render settings.