Viewports are gone and Black

After my rhino crashed, all viewports are gone from the bottom bar and are now black.
I have tried opening a old project becuase it did this before. I have also uninstalled rhino and reinstalled. I have watched videos on what to do and nothing is working.


Hello - please run the SystemInfo command in Rhino and post the results here.


Rhino 6 SR12 2019-1-29 (Rhino 6, 6.12.19029.6381, Git hash:master @ ae9d7fba5fda0b43002dc44a34e059a9a382db04)
License type: Educational, build 2019-01-29
License details: Cloud Zoo. In use by: Keddy7 ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-DM7886F

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1070 (NVidia) Memory: 8GB, Driver date: 3-7-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 389.12

Secondary graphics devices.
Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 8-15-2018 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-7-2018
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.12.19029.6381
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.12.19029.6381
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.12.19029.6381
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.12.19029.6381
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

I suspect the problem will be fixed by updating the drivers for both your GeForce and Intel 630 adapters.

Can you get to the Notification tab in Rhino?
I suspect there will be messages there telling you your drivers are old.
Double click on them to get help with updating them.

Does that get you sorted?

It did not work. Everything was updated.

What are the dates of your drivers now?

2/16/2019 All drivers were updated today.

Where, and how you checked for updated drivers will result in very different results.

New drivers for your GeForce were released 3 days ago:

New drivers for you Intel card were released 2 days ago;

Are these the drivers you are using?
I really am trying to help.

yes those are the drivers I am using

That’s really odd. I don’t understand it.
I’ll assume you’re still having the black viewport problem.

Are you running a sequence of commands that causes it to happen?
In Rhino Options > View > OpenGL, does it show the GeForce card as being used?
Do you have multiple monitors connected?

Yes geforce is being shown. I have tried with and without connected second screen. I can put it in safemode and it works but my project wont open in it.

Safemode blocks OpenGL and plug-ins. I didn’t see any extra plug-ins so my assumption is it must be OpenGL related.
I don’t know what to suggest.

Hello - but, not in safe mode and just opening plain Rhino, with no specific file, the viewports are black, is that correct?


A post was split to a new topic: Black Viewport