All four rhino viewports are black

Hi,

Currently all four of my rhino viewports are black. I can draw, but cannot see what I am drawing. My graphics card is updated.

I am on Rhino 7, Windows 10. Before today Rhino was working great. If there is any other information I can provide please let me know.

Rhino 7 SR11 2021-10-20 (Rhino 7, 7.11.21293.09001, Git hash:master @ 972ac562128b307e99f15e56dd11586c73e91ecb)
License type: Educational, build 2021-10-20
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Unplugged [45% battery remaining]

Standard graphics configuration.
Primary display and OpenGL: Intel(R) HD Graphics 4600 (Intel) Memory: 1GB, Driver date: 11-4-2020 (M-D-Y). OpenGL Ver: 4.3.0 - Build 20.19.15.5171
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.3 (primary GPU’s maximum)

Anti-alias mode: 2x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel
Render version: 4.3
Shading Language: 4.30 - Build 20.19.15.5171
Driver Date: 11-4-2020
Driver Version: 20.19.15.5171
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.11.21293.9001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.11.21293.9001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.11.21293.9001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.11.21293.9001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.11.21293.9001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Start by plugging your laptop into power.
Then update the old Intel GPU driver:

Your GPU does not meet Rhino’s system requirements.

The last option is in Rhino Options > View > OpenGL, move the slider to the left to reduce the OpenGL specification Rhino is asking the Intel GPU to support. You should find a setting that at least gets Rhino running and the viewports visible.

If you’re serious about running Rhino, start with this: