After Yosemite upgrade, command box misses the first key of every command

Super annoying.

I’m running 10.10 on a MacBook Pro (Retina, 13-inch, Late 2013), and after upgrading to Yosemite, the command box doesn’t ever get the first key i type. My muscle memory is so ingrained that it’s impossible to re-train myself to type space or dot first just to make sure the box is selected properly.

Is this a terrible mode or something? Can I have the old way back, where if i wanted to move something, i could just type ‘move’ from anywhere, rather than ‘mmove’; ‘circle’ instead of ‘ccircle’ and the like? Also, it even truncates the first key for every dimension…

It actually works fine in “use command options dialog” mode, but not in “command options in sidebar” which I greatly prefer.

Happens on every model, and I’ve trashed the preferences as well as the files in application support in an attempt to fix.

Thanks!

~Nicole

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-10-15 (5A554)
IronPython version: 5.1.2014.1006
Language: en (MacOS default)
OS X version: Version 10.10 (Build 14A389)

Plug-ins
None

Third party kernel extensions
com.Cycling74.driver.Soundflower (1.6.6)

Hardware information

Computer hardware
Hardware model: MacBookPro11,1
Processor: Intel Core i7-4558U CPU @ 2.80GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: Intel Iris (null)
Memory: 1024 MB
Screen size: 1680 x 1050
Displays: Color LCD

USB devices
Apple: Internal Memory Card Reader
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
Apple: Apple Wireless Trackpad

OpenGL information

OpenGL software
OpenGL version: 2.1 INTEL-10.0.86
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 0x
Mip map filtering: None
Anisotropic filtering: None

No one else has reported this on Yosemite, so I’m guessing that it is something on your computer that is eating the first character.

If you create a brand new user account and run Rhino there, does this still happen?

Huh, totally works normally on a new user account. Shoot! I haven’t added anything since moving to Yosemite. Well, not sure how to fix this, but thanks!

Any idea where all the various preference files are? I’d like to try removing it all and starting fresh.

you can reset the plist using the method outlined here:

http://wiki.mcneel.com/rhino/mac/resetprefs

.

I’m experiencing this problem as well, and resetting the plist didn’t do anything for me.

Same, I’ve reset the plist, removed all mcneel and rhino folders I could find in the library, and still no luck. The command options dialog mode also doesn’t actually work, because though the initial command types in fine, it loses focus for all subsequent dialogs, and I have to click in the text box to insert numbers and the like.

Any ideas how to troubleshoot this?

you probably have something installed on your computer which is interfering (some sort of mouse/trackpad/keyboard enhancer… some other 3rd party install which is doing ‘something’ etc…)

make a new user account and try rhino from there… i bet you won’t have the same problem.

(system preferences -> users&groups)

[EDIT] haha… nevermind… i should of read the rest of the thread (which i was already a part of) :confused: :-)

I believe you, but I'm really not sure how to find it out. Again, everything worked flawlessly before Yosemite.

Figured it out!

In Yosemite, Rhino seems to need the keyboard set to “U.S. English” in order to work, where I normally have my keyboard set to “Romaji” for english characters.

This is pretty easy to change for now, though I would prefer to leave my input method alone so I can quickly switch to Japanese.

~Nicole

I don’t have this problem myself, but this may help. It’s worth testing because it is a new change in Yosemite keyboard behavior:
Turn off keyboard autocorrection

It’s a check box on the Text tab of the Keyboard System Preferences page.

yeah, tracking down conflicting software can be nearly impossible.

it could be that Yosemite ‘broke’ the other software which is why you’re seeing it now.

I’m curious if others that are experiencing the same problem have the same software installed. but even that can be a pain to figure out.

maybe there’s some sort of trap which rhino can do to prevent it from affecting your rhino experience but that’s way beyond my skill set


(edit) just saw your last post. my guesses were off it seems :slight_smile: …maybe you’ve uncovered some clues for marlin to look at

This thread seems to have found the fix:

I actually posted the ‘fix’ here first. :wink: I still hope that all english input sources will work in rhino, not just US English! They worked before yosemite, so it seems possible!

~Nicole