Typing the letter twice to start a command


One problem has been annoying me which is, even since the latest few uploads the command line required for me to type one letter to “focus” on the command line, but it does not input the text I type. For example, if I want to ‘move’, I need to type one letter to bring it into focus, and then type M again to start the autocomplete. I wish it went back to where I could just start typing a command immediately into the command line. Is there some way to set this back? Thanks.


Hi Jack-

I’m having trouble replicating this behavior on my computer.

Can you please send me your computer’s specs? The easy way to do this is to go to Rhinoceros > About Rhinoceros > Click the “More info” button > Click the “Copy to Clipboard” button. Then you can paste the contents into a reply in this thread (or you can private message this to me or email dan@mcneel.com if you aren’t comfortable sharing specs publicly here).


Thanks Dan,

This error is actually happening on two separate machines. One of the specs is:

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-11-10 (5A580)
IronPython version: 5.1.2014.1006
Language: en (MacOS default)
OS X version: Version 10.10.1 (Build 14B25)


Third party kernel extensions
com.Logitech.Control Center.HID Driver (3.9.1)

Hardware information

Computer hardware
Hardware model: iMac14,3
Processor: Intel Core i5-4570S CPU @ 2.90GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 750M 1024 MB
Memory: 1024 MB
Screen size: 1920 x 1080
Displays: iMac

USB devices
HP: Deskjet 9800
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)
Logitech: USB Receiver

Bluetooth devices
Apple: Apple Wireless Keyboard
Apple: Apple Magic Mouse

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.0.43 310.41.05f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None


Hello Jack!

I was having the same problem, and found that setting my input method to “US English” fixed it. You may want to try that, if you are using a different english input method.

It’s in the Input Sources pane of the keyboard preference.


1 Like

Thanks Nicole!! That solved it.

I can finally type my commands in peace.