Command keystrokes, Win vs. Mac

I poked around for an existing topic, sorry if this is a duplicate.

Over in Win8 I can just type a command and it happens. I select an object, type “copy” and “Copy” comes up in the Command pane.

It seems that somewhat recently OS X changed how it responds to typing. If I select an object and type “copy”, I get “opy” in the Command pane and things don’t do what I expect.

Is there a UI change between Windows and OS X that requires a different way of entering a command from the keyboard? If so, that’s going to make like quite annoying for those of us who work in a cross-platform world.

hey jet
others were reporting similar problems a few month ago.

the problem was being caused by not having their keyboard set to U.S.

if you go System Preferences-> Keyboard-> Input Sources, what do you have set for your keyboard? if it’s something other than U.S ,try changing to u.s. and that should solve the issue you’re having in rhino… (which, btw, isn’t normal)

here’s one of the past threads:

I normally work in Kotoeri/Romaji, switching to US fixed the problem. Hurray, no more crazy typing.

Probably related: there’s a nasty, nasty Kotoeri bug in Yosemite before 10.10.2. Some of us had situations where it would randomly pick a different keyboard setting when we started typing. I’d be working in Romaji (say in email), switch to a browser for a web search, and as a reaction to the first letter I typed, it would first switch me to Hiragana then start taking keyboard input. The only “fix” for this was to switch back to a US keyboard. I read some notes on a third-party board that wiping a long list of preferences might fix it, but I couldn’t replicate that fix.

10.10.2 was supposed to fix this problem, but I can’t verify. I wiped all my broken Yosemite boxes back to Mavericks because they were unusable.

hmm… yeah, the other people experiencing the issue were also using Romaji…
it’s tough to say if it’s a rhino problem or an OSX problem but at this point, i’d say it’s leaning towards and OSX problem.

[edit several comments in to one]

OS X bug is still there – I switch to US, do a command or three, then I’m back in Romaji. Which is better than going into Hiragana, but still not a complete fix.

Over on my 10.9.5 box the exact same Rhino release operates as it should.

Will it help if Apple/Rhino customers file bugs with Apple on this?

Still seeing this on 10.10.5 (14F27) in Rhino 5.0.2 (5A865) but not in any other Apple OS X apps.

Still happening in 10.11.2 (15C50) and 5.2 (WIP) 5C83w

Ok, super frustrating time today. Happening in U.S. keyboard layout with 5.2 WIP (5C95w). I was working on a document yesterday with no problems. Opened it today, did a Duplicate, renamed it, and now the first character I type gets eaten.

I tried switching from U.S. to Romaji and back and I can’t even switch to Romaji. If this is an OSX bug and not a Rhino bug it’d be great if a dev could file a bug. I don’t see this problem with any of my other apps, from free stuff like Thunderbird and Emacs to $$$ apps like Adobe CS6.

This certainly seems like MR-1890 all over again. I’m not entirely certain what I should do to reproduce the behavior you are seeing. I tried:

Using RhinoWIP 5C133w on 10.11.3

  1. Switch to romaji keyboard layout
  2. Create new model.
  3. “Duplicate” (Command + Shift + S)
  4. Begin typing the new name of the file…the first character is not eaten.

Am I understanding your report?

That said, I still see MR-1890, so it looks like Apple has not fixed their bug. Why this is happening in Rhino - and not other applications - I could only speculate.

I had to reboot to fix that last problem, Kotoeri was basically “stuck” in some confused U.S./Romaji state.

I’m working with OSX 10.11.3 (15D21), 5C133w and I think I might have narrowed down the problem.

I opened a doc I was working on yesterday, keyboard in U.S. Typed in some commands and works as expected. Switch to Romaji and typed in the same commands, and they all work as expected. (Hey, rebooting fixed the problem! :slight_smile: Which is strange, because this hasn’t worked for me in at least a year. Select an object, type the same command, and the first character is eaten. Unselect the object, type the same command, first character is eaten. I played with it a bit and selecting/unselecting objects seems to have some relation to the first character disappearing, but I can’t find anything easily replicated beyond this:

  • set to U.S.
  • Launch WIP, open previous document
  • type “move”, WIP translates it to “Move” and provides a list of commands
  • ESC
  • switch to Romaji
  • type “move”, WIP translates it to “Move” and provides a list of commands
  • ESC
  • select an object
  • type “move”. “m” is never displayed, WIP capitalizes “O” and displays “Ove” but offers “Move” as the first command
  • ESC
  • type “move”. WIP translates it to “Move” and provides a list of commands

Another instance:

  • set to Romaji
  • launch WIP, select previous document
  • type “move”. “m” is never displayed, WIP capitalizes “O” and displays “Ove” but offers “Move” as the first command

And while playing around with Kotoeri and preferences I locked out the keyboard. I had to put it to sleep and wake it up to get text input back.

I’m wondering if it’s a bug related to Keyboard preferences. I’ve attached my current, I’m going to delete that and start a new one. (848 Bytes)

[edit: I’ve got a spare 70G partition just for testing things on clean OSX releases. I’m going to wipe that, install and upgrade 10.11.3, install Rhino, and test changing nothing but the Keyboard input language.]

I could repo it with the steps below. I’ll keep the volume pristine for now, I can install XCode and run a test program, collect logs, image the volume, or do anything else that can help diag this.

  1. Install latest OS X to clean volume, put on wireless, add a user
  2. Install Rhino as that user
  3. SSH over to my other workstation to get my Rhino key (oops)
  4. Run Rhino under U.S. keyboard, worked as expected
  5. Go to Preferences, add Japanese to list of keyboards
  6. Set to Romaji
  7. Run Rhino, type “Box” and see “Ox” with “Box” as the first suggested command

Ok, so basically you are reporting what is exhibited in MR-1890…which we can reproduce, but are unable to fix. Unfortunately, this bug seems to have disappear from OpenRadar but our records show that this is a known bug for Apple. Unfortunately, filing it again is an extremely onerous task. I can find similar issues on the Apple discussion forum (in Safari, for example).

Is there a tiny, test-case example that shows this behavior?

Not that I know of.

crumbs. I’m a registered developer and know a few others, if we all submitted bugs maybe it would get fixed.

Still seeing this in 10.11.6, it also happens when I’m typing in dimensions when I’m creating an object, first character gets eaten by a grue. I tried turning off “correct spelling automatically” in Preferences->Keyboard, no improvement.

Should I file a new bug with Apple and see what happens?

Do you know if the bug occurs in more recent versions of macOS? Sierra or High Sierra?

No, and we’re not upgrading to Sierra any time soon because of all the third-party software dependencies. We might stay on 10.11 until Rhino requires us to upgrade.

I would submit it to Apple on their bug system as well as OpenRadar.