4 Viewports in 5.0


#1

Hi ,

When in 4-viewports mode there seems to be a bug in my configuration. When selecting objects in a viewport, it is highlighted in another and all other 3 viewports change settings but not namings (fi right view changes to perspective while the window is still called right view).
It looks like a bug because this doesn’t happen in a 3-viewport or single viewport setting.

I am working with windows 7 professional with a AMD firepro m5100 fire gl v and a i7 m4800 processor.

Does anyone of you encountered the same problem and maybe have an solution for this?

Thanks! Rijndert


Amd radeon hd 8670m open gl issue
(Willem Derks) #2

Hi Rijndert,

Check these posts as they appear to describe similar problems.
Apparently no official solution yet but maybe a workaround:

HTH
-Willem


#3

Hi,

You most likely know about this but I found this article about display problems. http://wiki.mcneel.com/rhino/troubleshootingdisplayproblems
Checking the boxes ‘do not use open gl for drawing feedback’ and ‘use accelerated hardware modes’ worked for me.
I dont quite understand what the consequences are for rhino performance. Maybe you can explain.

Thnx Rijndert


#4

Hi Willem,

I have found another problem that occurs when ‘accelerated hardware mode’ is checked on and off. Normally when multiple objects are selected with pointer, a box is exposed with these objects and the object you choose in the box is highlighted in the window. This doesn’t work. The box is there, but chosen objects are not highlighted. This problem occurs also in 3 and 1 viewport mode.

Do you think these bugs will be fixed because I just bought the dell precision m 4800 for the purpose of working faster with rhino and maxwell (runs real fast on this machine).

Rgds, Rijndert


(Pascal Golay) #5

@jeff , any ideas here? Seems like this and similar has popped up a few times lately.

-Pascal


(Jeff Lasor) #6

It’s hard to tell without actually seeing the issue… It sounds like the “Choose One Object” highlighting isn’t working… However, given what I’ve read, it sounds like a cluster of issues…

Please stop checking and unchecking the OpenGL options without taking note what they do. They do not work in unison… they are all independent of each other. So if you check/uncheck several of them, and things then work, it is uncertain as to which option made things work. Try checking and unchecking them one at a time…and before checking/unchecking another one, make sure you check/uncheck any changes you made previously. Once you’ve exhausted all possibilities, then you can try combinations of options…

I also see no mention of which version of the video drivers are being used here, or whether or not they’ve been updated… AMD supports mobile FirePro cards, however, they are limited to specific laptop brands. The only one I’ve been able to find that supports the m5100 FirePro is the Dell Precision 4800 (which is apparently the laptop in question here). The latest drivers for that laptop can be found here:

http://www2.ati.com/drivers/firepro/mobile/13.152.4-whql-dell-mobile-x32x64-163382.exe

The first thing I would do is download those drivers and install them.
I would then make sure to put ALL of Rhino’s OpenGL settings back to the way they were before you started changing them.
Then I would start running tests to see if things are still broken…

If things are still not working, then we can go from there, and dig deeper.

-Jeff


(Pascal Golay) #7

Jeff, this looks like it may be similar:

-Pascal


#8

@pascal @jeff . Yes I believe I am having the same issue, and I believe it is a Rhino (4) viewport layout problem as in my post the problem is correct by using the (3) viewport layout or split viewport layout.


(Jeff Lasor) #9

Sorry, but I disagree… You mention flashing viewports and the inability to select objects… Rijndert is clearly talking about multiple object selection and objects not highlighting when you move through the list of ambiguous objects… IMO, that’s not the same thing.

That’s not to say you’re problem isn’t any worse than his…in fact, your problem sounds a lot worse than Rijndert’s… However, I don’t know why the number of viewports has anything to do with it is a mystery. Is it only 4 viewports that cause the problem? Or is it anything over 3? What happens if you create 5 or 6 viewports? What happens if you create floating viewports…do they flash as well?

That being said, I’d rather not convolute this thread with other, unrelated issues… and try to focus on exactly one problem at a time. But if these issues do turn out to be the same, then we can continue a single thread discussion.

Thanks,


Rhino Video Card Problems?
#10

Not a problem. If you want to continue the conversation in my thread I about my problem that would be great. I will post my reply there.


#11

Hi

Unfortunately the problems remain the same after installing new drivers via AMD driver autodetect programm. Multiple selection box and view ports don’t work properly at all.

I don’t understand though why new drivers are Radeon type while the original is Firepro m5100 fire GL V. Why?

How can I get Rhino 5.0 to work properly on a brand new Dell Precision M 4800?

Rgds Rijndert


#12

Out of curiosity,did you put Rhino 4 on your new machine? I didn’t and don’t have access to it, but would be curios if you experienced the same problems in Rhino 4. Not that we should be going backwards…


#13

Good idea. First have to solve problems with the newly installed video drivers.I will keep you informed!


(Pascal Golay) #14

@jeff Jeff, only is a later post- you know best, and I’ll butt out after this , but the initial post, at the very top, seems to me not concerned with the ambiguous selection…it sounds at least somewhat like some other reports we’ve been seeing here and on Apoio. ( apoio conversation 322140 for example, and Amd radeon hd 8670m open gl issue which is also specifically a 4 viewport glitch with an AMD card.

I’ll leave you to it now…

-Pascal


#15

I completely reinstalled my laptop to DEll factory settings and installed Rhino 4.0. Rhino 4.0 seems to work fine with the graphic card. Then I installed Rhino 5.0 and it has the same problems as before (viewports and selection). Furthermore I got a few error messages during installation and valadition (its weird anyway that one has to fill in the same information for setup and validation (website construction?)

So Rhino 4.0 deals well with the graphc card.


#16

Correct Pascal.

I have installed Rhino 4.0 and it seems to work fine with the graphic card in my laptop. So it is really something with Rhino 5.0.

Rgd Rijndert


#17

Could you post the error messages?

IIRC, there is a little link to click to “skip registration” when you validate, so you do not have to fill in the info twice.

–MItch


#18

Hi,

When I startup 5.0 in safe mode everything seems to work fine, but graphic cards are not plugged in. After closing safe mode and starting up regular 5.0 everything seems to work fine.

Only when a viewport was used in rendered mode i got some problems but only for a short while. Multiple selection and 4 views layout seem ok too for now.

So maybe this is the solution. Perhaps it has to do with order of loading plugins. I dont know. I will keep you informed

Rgds Rijndert


#19

Hi,

there was one message that popped up while installing rhino 5.0. I didnt make a screenshot so i would have to reinstall rhino again to see if it popped up again and then make a screenshot. It occured while filling in name, Phone number etc.

The other error message occured during validation:

rijndert


#20

The validation server was down for awhile, this was likely the problem. It should work now.

–Mitch