Rhino Video Card Problems?


#1

So I just got a new machine with an
AMD Firepro M6100 FireGL V.
Driver Date: 6-3-2013
Driver Version 9.18.10.3204.

It’s a 64bit windows 7 machine and when I am in the default 4 viewport view style, there is defiantly some graphic issues. Views just jump around to different styles and I can’t select elements is some views.

In this video I am basically just clicking on the cylinder shape in the perspective veiw to select it, which it won’t select, but just the mouse clicking cause the other views to jump.


Amd radeon hd 8670m open gl issue
Amd radeon hd 8670m open gl issue
4 Viewports in 5.0
Amd radeon hd 8670m open gl issue
4 Viewports in 5.0
(Brian James) #2

Hi,

Can you confirm what service release of Rhino 5 you’re running? The latest is available here and that would be the first thing to try. http://www.rhino3d.com/download/rhino/5.0/sr

If that doesn’t help, please check for an updated graphics driver from the manufacturer of your computer or from AMD. I see some options on the AMD site but I’m not sure who made your laptop… I’m pretty sure it’s a laptop given the M in the GPU name. New machines often ship with outdated drivers and this one being half a year old may be the issue.


#3

Should be the latest version.

Version 5 SR7 64-bit
(5.7.31207.7545, 12/7/2013)

I will check on the driver and let you know.

On side note it is pretty frustrating that software has become so specific that it not only matters what video card you have but what driver you are running. I know that it’s not only Rhino but can’t you broaden the base of what works with Rhino.


(Brian James) #4

Okay that’s the current SR which is good. I know it’s frustrating and we do try and make Rhino work on as much hardware/software as possible. The issue when there is a problem is often in the combination of software and hardware installed. It ends up being a bit of detective work to figure out what is causing the error with so many possible combinations out there. The next thing to check on is your Windows updates to make sure they are current. For example, the Microsoft dot net library. Make sure this is up to date and that the update actually installed.


(Pascal Golay) #5

Dennis, does Windows Task Manager > Performance page show the CPUs going nuts when Rhino does this?

-Pascal


#6

Doesn’t seem to be. It’s pretty much consist with what is shown.
There is an updated video card driver, so I will try and update it later this afternoon. I will also try make sure I have an updated .net library as well.


#7

So i updated the driver from the dell website. No luck although it looks like it looks like the open GL in the new driver is the same date.


#8

So turning off accelerated hardware models. Fixes the issue on my side. So it probably does have something to do with the openGL driver.


#9

OK new development. In the standard (3) viewport layout, with “Use acclerated hardware modes” on. Things are much more stable. Also if add a new viewport or split an existing viewport things become more stable. So it seems to be just the (4) viewport layout.


#10

Hi,

I had the same problem . Graqphic card settings:
Frame refresh rate changed to 'always on’ instead of default ‘application dependant’ seems to do the job for me.

Rijndert


#11

Hi, I sorry but I forgot I turned of accelerated hardware mode in which case 4 viewports work fine.

So changing the frame refresh rate in the graphic card settings does not work.

Rijndert


#12

Hi,

You most likely know about this but I found this article about display problems. http://wiki.mcneel.com/rhino/troubleshootingdisplayproblems
Checking the boxes ‘do not use open gl for drawing feedback’ and ‘use accelerated hardware modes’ worked for me.
I dont quite understand what the consequences are for rhino performance. Maybe someone can explain.

Rijndert


#13

@pascal @jeff Here is another youtube video showing the 4 viewport jumpyness and in ability to select items vs the more stable 3 viewport layout.


#14

@jeff To answer you question it seems to only be the 4 viewports if I split the screen to make 5 viewports or add a new floating viewport things settle down as welll. No jumping around. See below


#15

More testing, more unanswered questions/unexpected results. So don’t know why but if I copy the model into a brand new model things aren’t as bad. See below. Also it didn’t matter in the old file whether it was curves, surfaces, polysurfaces, extrusions or all at once it still did the same thing.

1 more comment/question. In going back and looking at what is going on (in my case) it looks like the viewports are getting confused on what should be drawn were. For instance the “top” viewport when I click might draw what is supposed by in “Front” viewport. Could that even be a possibility?


#16

exactly the same happens to me. the viewport seems to ‘forget’ what to draw, or maybe draws more than 1 view at the same time over the active viewport. this could maybe answer the flickering…

one difference to your problem: in my case the ‘split viewport’ doesn’t change anything.

http://discourse.mcneel.com/t/amd-radeon-hd-8670m-open-gl-issue/4775/5


#17

When I startup 5.0 in safe mode everything seems to work fine, but graphic cards are not plugged in of course. After closing safe mode and starting up regular 5.0 everything seems to work fine.

Only when a viewport was used in rendered mode i got some problems but only for a short while. Multiple selection and 4 views layout seem ok too for now.

So maybe this is the solution. Perhaps it has to do with order of loading plugins??

Thanks Rijndert


#18

@Rijndert No luck here. Tired starting Rhino up in Safe mode and it does work fine, but that is with the graphics card be utilized. Starting Rhino up in Regular mode and nothing has changed. The same as it was before. I tried disabling pulg-ins to see if one was causing an issue, but still not luck. Glad to hear you were able to get it resolved.


#19

same here as dinelson75…working when started in safe mode, but no luck when starting in regular mode…


(Willem Derks) #20

Hi @jeff @pascal

I’ve got the same symptoms on a new machine with a
AMD Radeon™ HD 8970M 4GB GDDR5, (Enduro dynamic switchable graphics).
Not sure of the switchable part is relevant but I thought I’d mention it.

It’s a new laptop with just Rhino 5 64b installed no plugings no nothing.
Windows 8.1 pro.

Is there any news on the issue, can I help in testing/bug tracking?
Let me know if so.

-Willem