Zoom extents too far but no objects show up

Zoom goes really far out even though there are no objects. I already did a selall + bounding box. I don’t understand what could be causing zoom extents to go all the way out to space

1 Like

How big is the bounding box after SelAll and BoundingBox?

It’s big but it’s still limited to just the objects. If I do a zoomextents after making the boundingbox it still zooms far away. I wonder if it’s trying to include the origin (0,0,0) in the view?

Ok. I moved all the objects to 0,0,0 and did zoomextents again this time it worked as should. So my guess is that zoom extents is forcing the world origin (0,0,0) for some reason to be included. I don’t know how to work around this.

I have not experienced Zoom Extents including the origin. Perhaps you have a small object, possibly a point, at or near the origin.

Hi Stefano - if you have not sorted this out, please send us the file - tech@mcneel.com, or if it is large, www.rhino3d.com/upload.

-Pascal

No objects there. I do have blocks in the file. Maybe the blocks have base points set up at 0,0,0?

I’m having the same issue. my camera settings:

image

This is becoming a real problem as i can’t use any perspective views.

UPDATE: I deleted the offending views and added new ones. Working for now

Hello - most likely you have a curve or other object in ‘outer space’ If you can zoom the expected scene in one viewport, window select around everything and then run Invert and see if anything is selected (the command line will say) If it is not an expected thing, Delete…

-Pascal

I did that found three linear dimensions out in space. Invert is my new friend. Thanks man.

1 Like

this happened to me as well… i dont know what i did to get it right… i just turned on control points of all selected objects and from that point on zoom extents was working fine. it had to do something with blocks insertion point moved from far away and that point was somehow remeber when moved. i think this is a bug because you have no control over the behavior…

Hi Ivan - if you have a reproducible example file, we will take a look at it!
-wim

I cannot recreate it right now but i am sure it had something to do with replacing blocks from other file where there were changes made close to the origin and then the block was replaced in the other file where the block was far from 0.

Zoom extents was still capturing origin even when there was no physical geometry of any object present anymore.
I tried purging, refreshing blocks and nothing helped. Then i turned on control points of all the objects and suddently zoom extents was behaving well…

I dont know which action actually returned it back to normal. But it has to be with insertion points somehow unrefreshed behind the scenes

I found out that when replacing blocks in the model it generates some locked objects in the background which i am not aware of because i never have set manually to any objects to be locked. i only lock certain layers

i suspect blocks replacement to be the reason that suddenly i had many objects locked and not visible at all.

is there some mechanism in rhino which locks objects (maybe some temp duplicates when replacing blocks) automatically during some operations? what happened to me is pretty unpredictable behavior messing the model unknowingly…

Hi - when you enter BlockEdit mode by double-clicking on a block, all objects that are not part of the block are locked.
-wim

it happened to me all the time that when working with blocks there were new objects emerging in the model out of nowhere.

i hope this bugfix https://mcneel.myjetbrains.com/youtrack/issue/RH-56469 was why it was happening all the time

Hi Ivan - Let us know if that fixed that, yes.
-wim