Wirecut doesn't seem to be working on Mac

Hi All,

I’m a newbie and I’ve been following a tutorial where I have a polysurface being cut with a polycurve and for the life of me, I’ve tried every combination and I can’t get it to work like it does in the video tutorial. I’ve even tried to extrude and split, boolean split and none of it works. With the wirecut, after I return on the Wirecut depth, the command just ends. It doesn’t ask me to select object which to keep.

Here is a copy of the fileWireCut.3dm (67.3 KB)

Any advice would be greatly appreciated…

Thanks
Michael

Hi Michael, it looks like you’ve already made the cut needed… can you explain more. Wirecut will use the normal (Z axis) of the active construction plane or Cplane as it’s called for the direction of the cut. In this case your cutting profile is also not touching at two corners and can’t be joined into a closed curve. This might be the problem but again I’m not sure what you want to cut at this point. Let me know and I can try to help more.

Hi Michael,
I made you a quick video on a possible Wirecut scenario on this model.
Also I closed the model so it is solid and it is attached. Now the Wirecut produces solids.
This may not be exactly what you want, but it may give you a tip or two that will get you going.
using wirecut.3dm (248.3 KB)

Sincerely,
Mary Fugier

Thanks so much for the quick response. Thanks for video, nice to see it. Awesome customer service. So if I split the curve I was able to do the wire cut. If I had a closed curve it wouldn’t wire cut.

I’ve attached the Wire Cut before I split it, so you can verify whether you can wire cut on the mac.

Also, If I extrude the curve and try and split the polysurface it comes up with the following error
Split failed, objects may not intersect or intersections may not split object.

I’ve included both examples in the file. The first is the wirecut, the second is for a split.

I’m trying to understand how to work out why this function doesn’t work, essentially how to debug it.

Thanks
Michael

WireCut Problem.3dm (225.1 KB)

it’s buggy behavior (imo) that’s particular to situations being shown in your model.

WireCut can work here sometimes but that split just won’t work.

a quick (soundless) video showing various attempts at a WireCut… if i set the depth higher than the ring to cut, it fails… if i set the depth (via snapping) to the exact height of the ring, it succeeds… if i cut only a portion of the ring, it succeeds… cutting downward/below succeeds… then i draw a rectangle instead of your curve and it always succeeds where your curve doesn’t.

then Split… at first, i call _Intersect on the two objects and you can see the entirety of the intersection hasn’t been found… there are portions missing… this intersection curve is what Split will use to split along but since it’s an incomplete intersection, the command fails.

if you move the splitting surface a little bit forward or back, Split then works.

when the two surfaces kiss(?) each other in the way yours have (portions of the surface perfectly overlapping the other), the intersection can fail… this will show up in the boolean commands as well.

Hi all,

WireCut is basically a shortcut for Extrusion+Boolean. If you can do these operations separately, then you can do it with WireCut. The reason WireCut is failing sometimes is because the Boolean is failing in tangent and other situations.
As for the kind of curve to use, the general rule is that closed curves can be extruded in one direction (capped to create the solid to Boolean with), whil e open curves are allowed to be extruded in 2 direction.

See the example to show how the Boolean fails.


WireCut Problem RI.zip (84.9 KB)

Hi,

Have you tried the same wirecut on Windows? Also, it’s hard to work out why the wirecut or boolean fail when all you get is a message saying it failed. What is the procedure to determine why these operations fail?

Thanks
Michael

The easiest way to see why a boolean failed is to intersect the objects and to examine the resulting geometry (curves and points).