WIP update - WTH...?

So, last night, the WIP told me it had an update, I let it install, and then it told me I had to restart the computer. Since I was going to bed anyway, I simply shut down the computer. This morning, on starting the computer I get this:


Then this:


So I punched the Restart Now button and restarted the computer again. No new error messages, but when I open the WIP, I see it hasn’t been updated and it tells me an update is available…

So, I tried letting it install again… This time it seems to have worked. No messages and it got updated. So this is just a heads-up…

I installed WIP (7.0.19351.11415, 12/17/2019) yesterday without any problems. But last week I had an unexpected “system reboot is required” which may have been associated with installing either last week’s WIP update or V6 update. No idea of the cause.

FWIW, I haven’t had Rhino requiring a reboot since I installed a daily WIP on November 28th.
Did you keep that log file, Mitch?

Yeeepppp… (changed the extension to .txt for upload)

Rhino_WIP_20191219093116.txt (51.8 KB)

Paging @brian to see if there’s any light to shed here…

The Helvetosaur knows all the tricks. This is Genius Mitch!

Ugh. I have another customer experiencing a similar problem. Except for him, the restart message never goes away, and Rhino never installs. I’ve passed your log onto the FireGiant team - the people who write and maintain some of the underlying install technology we use. I hope to learn something more soon.