Windows freezed when opening Rhino6. Issue Hybrid graphics system

Hi, in my Dell Xps 15 I used Rhino6 with no issue until the last Windows Update (July '19). Now when opening Rhino, after a couple of seconds the whole windows system get freezed (no use of mouse, keypoard or touchpad); the only solution is to force the laptop shutdown manually using the external button. It seems related to the use of the use of a Hybrid graphic system, with 2 cards (Intel + AMD Radeon), since if I disable the first one, Rhino seems to work, but with lower graphic performance.
NB: the Graphic Cards drivers are the last update.

Any suggestion?

Thanks

Here my specs:

Rhino 6 SR16 2019-7-9 (Rhino 6, 6.16.19190.07001, Git hash:master @ a8b4ee102e9e0eb1d11825df063e13f96d518f93)
License type: Commercial, build 2019-07-09
License details: Cloud Zoo. In use by: Vincenzo Montefusco ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-A458QET

Hybrid graphics system.
Primary display: Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 5-28-2019 (M-D-Y).
Primary OpenGL: Radeon RX Vega M GL Graphics (AMD) Memory: 4GB, Driver date: 12-6-2018 (M-D-Y). OpenGL Ver: 4.6.13543 Compatibility Profile Context 25.20.15002.58

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 12-6-2018
Driver Version: 25.20.15002.58
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Geometry Gym\Rhino3d\ggRhinoIFC.rhp “ggRhinoIFC” 1.7.11.0
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\Iris (1cd9c8f5-c901-426c-8e80-d6a2e2b18bba)\1.0.6911.20081\Iris.WinR6.rhp “Iris” 1.0.0.0
C:\Users\vince\Downloads\elefront421\ElefrontProperties.rhp “ElefrontProperties” 1.0.0.0
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - you should be able to force a ‘High performance’ mode on the graphics system so that it uses the AMD card only. If disabling the Intel gpu results in poor performance (did I understand that correctly?) then I’d guess Rhino is not seeing the AMD at all. What does your Options > View > OpenGL page show you about the video?

-Pascal

In the past there have been many reports of Windows Update, which seems to have it’s own idea of what is the latest video driver, installing an older driver than what you’ve been using. Could this have happened to you? I notice your AMD driver is from 12-6-2018. Do you know what it was before the Windows Update, and whether it is actually the latest available from AMD?

Thanks for the answers.

@pascal Here the OpenGL option

I also paste the specs after disabling the Intel Graphic Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-A458QET

Non-hybrid graphics.

Secondary graphics devices.
Radeon RX Vega M GL Graphics (AMD) Memory: 4GB, Driver date: 12-6-2018 (M-D-Y).
Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 4-12-2019 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

@AlW , thanks. This is actually the last version. About the AMD, even if on the website it is written Gen-19, after the installation it shows Dec-18. To be honest I don’t know the older version installed, and the Roll Back Driver option is now disabled

Hi Vincenzo - I would completely uninstall and reinstall both drivers.

(Yours is not nVidia of course)

-Pascal

Hi, the problem seems to be solved, thanks!
Here some comments for people having the same issues:
Basically no problem about unistalling and reinstalling the AMD-drivers. About the Intel-drivers, it was a little tricky: there are problem installing it from the Intel website (found different error messages), I had to install it from the DELL website update service, which in the end installed a different driver release (to the last update). Here the ‘working’ system settings:

Hybrid graphics system.
Primary display: Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 8-15-2018 (M-D-Y).
Primary OpenGL: Radeon RX Vega M GL Graphics (AMD) Memory: 4GB, Driver date: 12-6-2018 (M-D-Y). OpenGL Ver: 4.6.13543 Compatibility Profile Context 25.20.15002.58

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Thanks again

1 Like

Method to update Intel graphics drivers with the latest from Intel

Rhino 6 likes up to date video drivers, and “update your video drivers” is a frequent refrain on this forum. However if you have an Intel graphics adapter which was originally furnished with a “customized” driver it may appear impossible to update the driver with the latest from the Intel website.

I have found a method to get around the blocking of the driver update and manually install the driver update. The key is to use Device Manager to uninstall the adapter after checking the box to delete the software for the device. The adapter then disappears from Device Manager but will reappear after a “Scan for hardware changes”. The new driver can then be installed manually through Device Manager.

Attempting to update the driver through Device Manager without uninstalling the device and deleting the software resulted in a message that the “best software” was already installed and termination of the update process. Similarly attempting to manually install the updated driver after deleting the device but without checking the remove software box resulted in the device and old software being automatically reinstalled when the computer restarted.

Original post: Updating Intel HD Driver