Why is my file so slow when I open it?

I’m working on a file (~260mb) which every time it opens I have to wait about 30 minutes for it to become usable. The first 30 minutes, commands have a huge delay (5-10 seconds) if they even work at all. Even zooming in and out or panning has the delay. Somewhere around 30 minutes after opening this delay is gone and the file becomes more or less fine to work with. Additionally, when this file is open my computer will completely freeze 1-2 times per day. This happens more often during that first 30 minutes after opening. I’m using the file to to render with VRay. I have a lot of materials but I have tried to keep the file size down by using proxies.

I realize that this issue could likely be solved by increasing the performance specs of my computer but I am really trying to figure our what specifically is causing this and what I can do in the interim to make things run smoother.

A little about my computer:
CPU - Intel ® Core™ i7-7700 CPU @3.60 GHz (8 CPUs)
RAM - 32GB
GPU - AMD Radeon R7 450
256GB SSD (15-20GB of space left)

My file audit:
Document Manifest:
Texture Mapping: 1840 active, 1 system.
Material: 433 active, 2 system.
Line Pattern: 3 active, 3 system.
Layer: 161 active, 1 system.
Group: 118 active.
TextStyle: none.
Annotation Style: 5 active, 7 system.
Light: 99 active.
Hatch Pattern: 9 active, 9 system.
Block: 210 active.
Model Geometry: 35683 active.

Total: 38561 model components. 23 system components.

Audit Summary:
Table tally:
161 layers
210 instance definitions
5 annotation styles
0 fonts
99 rendering lights
3 linetypes
433 rendering materials
Object tally:
26361 normal objects
0 locked objects
7853 hidden objects
0 deleted objects (in undo buffer)
1469 block definition objects
0 reference normal objects
0 reference locked objects
0 reference hidden objects
0 reference block definition objects
No errors…

Thanks in advance.

Please display your ‘Notifications’ panel from the Panels drop down menu in Rhino to see if there’s a notification there about a possible newer driver for your graphics card. Double click it to see the details and a link to the GPU manufacturers driver download site to check.

If that doesn’t help, choose “System Information” from the Help drop down menu in Rhino 6 and return the text it reports back in a reply.

You might also try temporarily disabling V-Ray in Options >Plugins and see if the symptoms disappear… there have been lots of reports of “slowdowns” with V-Ray…

Indeed, I need to download an update for my driver. I tried but I got an error message saying “Install package failure.” I’ve reached out to my IT department for assistance on this. In the meantime, here is my system information.

Rhino 6 SR14 2019-5-7 (Rhino 6, 6.14.19127.17141, Git hash:master @ 5b633aaa430941b76f5789a0ce3bb670ce06947a)
License type: Commercial, build 2019-05-07
License details: Cloud Zoo. In use by: lind ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: FOTENN-WS01

Non-hybrid graphics.
Primary display and OpenGL: AMD Radeon R7 450 (AMD) Memory: 4GB, Driver date: 3-15-2018 (M-D-Y). OpenGL Ver: 4.5.13507 Compatibility Profile Context 23.20.15032.11

Secondary graphics devices.
Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 2-28-2018 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.5
Shading Language: 4.50
Driver Date: 3-15-2018
Driver Version: 23.20.15032.11
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.14.19127.17141
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.14.19127.17141
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.14.19127.17141
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.14.19127.17141
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

The Notifications Panel described in my first reply should be telling you that BOTH of your display drivers need to be updated.

MItch’s Vray comment is a real possible cause too, but the display drivers need to be updated in any case.

It was only giving me a notification for one driver.


I did end up getting it installed but still having the issue. Will try disabling VRay next. Would be pretty unfortunate if this was the case…

Here’s a link to the current Intel driver:

It looks like the Radeon R7 450 is only an OEM card:

@Helvetosaur was correct. Disabling V-Ray made it open smoothly. Will bring this to the Chaos Group forums. Frustrating how many bugs seem to be traced back to V-Ray.

Thanks guys.