Rhino 5 performance affected by network connection

I I am having a problem since about a month age with Rhino. files take really long to open (not big files, around 100mb), and sometimes it just freezes and the file will never open. once its open, and I try to render anything (I use VRAY 2) it freezes again.

I just discovered that if I disable the network connection, everything works fine. any idea of what could be causing this issue?

PC specs:
Windows 7 professional
Intel Xeon E5620 dual processors 2.40 GHz
ATI FirePro V4800 graphics

any help would be grately appreciated.

Not sure if this will help but I had a similar issue with Rhino hanging on start. Turning off the internet solved it for me as well.

The problem in the end was a plug in trying to call somewhere that did not exist. I figured it out by watching the startup screen and noticing which plugin was being loaded when the problems started.

Also when Rhino did finally start up I had an error in the command line for that plugin amongst all the normal stuff.

Thanks for the advice, attached a screenshot of when it gets laggy.

also, when it finally loads I get the following error:

File “C:\Program Files\Rhinoceros 5.0 (64-bit)\Plug-Ins\VRayForRhino\Misc\VRayForRhinoV4_tb.rui” is already open.

thats the only weird thing I can find once it loads.

any advice on how to stop this?

In Options > Toolbar, select this RUI file and SaveAs to a writealbe location. That should sort this part out.


@brian , @JohnM , any thoughts on this?

@AjotojA, are there resources like texture maps or materials or linked blocks on the network?


nothing, I work with everything on my local drives to avoid that exact issue.

If you block Vray, and other non-default plug-ins, (options > Plug-ins page, > Enabled check boxes) per plug-in, and open the same files, does that make any difference?


ok, I tried disabling the plugins at start up (VRAY and Badger), the only two plugins I’ve installed since I re-installed everything yesterday. same problem.

when you open Rhino for a new project(not a previous file), it will load fine with the plugins. if you try to import or open a file once rhino is open, the same thing will happen, it will stay there for a long time.


Hello. Something you can try since all else seems to fail…

  1. I prefer doing my own updates and not having the McneelUpdate Service running constantly in the background, so I disable it using a free Microsoft program called AUTORUNS which can be downloaded here:
    You don’t have to install Autoruns.
    Just unzip the files to a folder and run the autoruns.exe file from the folder.
    Once open, Autoruns lets you see every program that is set to start with your system and additional services. Be careful in this program!
    Click on the Services Tab and Un-Tick McNeelUpdate. Close the program and restart windows. If you need the service again you can re-tick it and reboot.
    Autoruns works ok Xp, Vista and Win7 and probably Win8 too.
  2. Check that your firewall isn’t blocking McNeelUpdate, or Vray, and allow through your firewall. I had lots of trouble getting Vray to render, even on single machine, until I found a setting on Comodo Firewall that was filtering loopback( Vray requires access to this IP loopback even if you’r rendering on single machine. I disabled filtering in my firewall and Vray started to render perfectly.
    Hope this helps. Michael VS

Since this problem exists on your local computer, even in safe mode, it should be possible for us to reproduce in the debugger here. Please upload the file to me at http://www.rhino3d.com/upload?to=brian@mcneel.com

Does it only happen when it is the first file to open after starting Rhino? Is it slow if you start a new, empty model first?

when I start a new empty model it loads just fine, its when I try to open a file, either by clicking on it or by opening or importing it from within rhino.

Do you have any solution to this problem? We are currently facing the same issue as described and need assistance – urgently.