Why does this extrusion come out sharp?

I have two curves with rounded corners, but when i extrudecrv between them the corners come out sharp. Why? When extrusion is selected it clearly shows where the extrusion should have been. This is persistent across multiple display options (arctic, shaded, rendered, etc). See picture below.

EDIT: additional information, when I “rebuild” the cornered part of the curve with 15 points it comes out rounder. I tried rebuilding with 100 points for a smaller deviation and smoother corners, but when i extrude the one with 100 points it comes out bad like in the picture above.

It’s just the display mesh, don’t go messing up your actual geometry. See Rhino Mesh Settings [McNeel Wiki]

1 Like

Hello - in this case, my guess is that running DivideAlongCrease > SplitAtTangents=Yes will sort out the meshing.


1 Like