What setting to add shadow in shaded view?

Hi,
V5
to indicate the shape better I need some shadow under the T piece, else it looks like a single planar face in ‘right’ view. and would help make for a better display in perspective view.

How can I achieve that ?

Cheers
Steve

You can turn on shadows in the Shaded display, but my guess is you won’t like it.

Options > View > Display Modes > Shaded > Shadows, click Shadows on.

1 Like

Hi,
attached results, it has no idea does it of the shape and what the shadow would be, and is placing shadow where it wouldn’t exist.

You’re quite right its rubbish at it !

oh dear.

Is that the only option by the time V5 was developed ?

is V6 any better ?

Attached the model.
T piece location.3dm (148.7 KB)
Steve

Hi @Steve1
I don’t know what it looks like in V5 (no longer installed), but this is V6, default scene lighting, lousy old GTX950M on equally lousy old Asus laptop.
-Jakob

Hi,
Thats the shadow one should be getting with light to one’s left and beyond the object.
What does the ‘right’ view look like ?

Its a bit dark, representing bright sun, can it be made to represent a hazy sun or single lamp room lighting , a weaker shadow in other words. ?

Steve

I wonder if you would get a better result using a copy of the Arctic in V6 that uses ambient occlusion instead of shadows, then modify it to display layer colors, surface edges, and isocurves like Shaded does assuming that’s what you’re after.

It might be worth a try.

1 Like

John-
Hi !
Yea, A-O would be the preferred answer for this particular application.

Shadows as you rightly pointed out wouldn’t give the intended result. Too many things don’t fit right in a planar/orthogonal view (lighting, position, direction, component placement/alignment … )

All the best -
-C.

Hi, I am V5.
still not solved this yet Its something I originally thought would be a viewing option, soft shadows to differentiate the items from themselves.
Take a look at the slotted bolt heads, they vanish, the internal of the C beam, no indication it is a C beam.
then I select artistic, I lose the colours I need but gain shadow, so if I do a screen grab of both, place each into photoshop as layers and make artistic layer 21% and multiply as layer mode, I get a bit of shadow, enough to show the true shapes, see bolt heads etc,
But surely can we not have a shaded with shadow option ?
I need the colours to show the different elements in my models but cannot get sensible soft hazy sun or cloudy bright shadows.


turn on artistic view and make 21% multiply.

or 42% is nice


and here is artistic at 100% normal.

Are there no settings in V5 for shaded to give us a soft shadow as truly SHADED view needs it. I see other CAD prog images and they have shadows and colours.

Does V7 solve this ?

Steve

Hi,
I see Fred_C and Oct31 for this thread when I click my icon top right but I cannot see any reply to this when I visit the thread, something really odd going on, also I paste thread addresses in Msoft Word and can click them and go back to a thread, great way of keeping control over what was posted to what forums, but now I click the link and I get a blank page, so whats happened to this website, its messing me about.

Steve

On Oct 31 2019 -I just added tag “Rhino 5”
Link to the thread with several answers :thinking:

Edit: Try change color via color by object
snap00 11-8-2020


Does that work?

Hi,
Fred, thanks, but no, I do need subtle shadows in Shaded view, do we not have a view that just adds in a little shadow ?
Like my ‘artistic view’ that Rhino does but with shaded view colours.
Surely I shouldnt have to combine a printscreen of that with a shaded view and use photoshop for a client, but I am on about helping me whilst working on it as well, as soon as I go to side view the objects of same colour become one, I need to show depth, if something is in a deep area, a shadow denotes how deep into the object something is, but a different colour it could be at same plane as front of object.

Its such a basic need, right there on page 1 of visuals in 3D.

how does V6 overcome this ?

Steve

Hi Steve - you can set the Shaded mode to use Scene lighting, turn on the skylight in the Lights panel, and get not great but maybe usable soft shadows in Shaded.

-Pascal

Hi Pascal,

note I am V5,
I look in rhino properties select display shaded cant quite see the settings referred to, here is what I see, I try for that indicated, the face goes white bit no shadows, lower riight is it in perspective before change, as you see shaded in ortho view is useless at showing a chasm there.

Steve