What is up with rhino lights and their "brightness" values

Maybe a weird opinion: I love using Rhino to render. I’ve been doing it a while, mostly for barely realistic/stylized renders, admittedly “uncanny valley” at times but always with interesting lighting.

I typically use the Spotlight. It’s the most versatile, and I basically treat it like I’m positioning studio lights. I will usually use 3 or 4 lights.

I cannot figure out how the brightness settings work. I will set three lights (A,B and C) to equal “percentages” of 100. A=20 B=30 C=50. It’s too bright! Let’s lower to A=15, B=15, C=30 (noting also that “wait this doesn’t add to 100 anymore”), and it’s too dark. So I’ll move to find a happy medium, find a sweet spot and get to re-positioning and tweaking, go back to my lights panel, and now the ratios have somehow been changed to something like A=1.37 B=7 C=17. What? Back to tweaking, and this time, once I find a sweet spot, I will lock all light objects so I can’t change them again.

This behavior has been across every Rhino 8 file, light type, etc. since the preview release, and now I’m confused and wondering if Rhino 7 was like this too (but honestly, it would take me all night with R7 to wait for just one raytraced view to confirm, while R8 can update every minute or so).

I don’t know if any of this is a bug or collection of bugs, or if I just don’t know what I’m doing.

TLDR; Can someone please explain the logic behind the lights and their brightness settings?

I mean I don’t use the Rhino renderer, I use an obscure artisanal discontinued plugin…or really spotlights (just HDRs and actual lit-up geometry) but I’m not seeing intensity values for lights changing as I edit others.

One odd thing you mention about setting the light values to “add up to 100%”? That’s now how that works? All the lights in a scene don’t “add up” to 100%, it’s just “100% of the max value of a light”…well except that you can go past 100%, it’s just a scale value.

Now cutting the light values in half and it turning out darker than you expect sounds like you should look at the Gamma setting on your render output, that’s what that’s to correct, dark shades on screen look darker to our eyes so the contrast is all weird without that set right.

Yes, yes. I know the percentage I mention isn’t how Rhino lights work. I was trying to point out that I usually use it as a helpful way of turning up brightness of each light relative to the others. If they were real lights in a studio I’d have a bright key light, a somewhat less bright secondary light, and maybe a soft back light. 20+30+50 is just a simple ratio as a starting point so I don’t start with all the lights maxed out equally.

The aggravating thing is seeing the values change without my doing anything to change them. I’ve been working on it since I first posted here an hour ago, and the values keep changing to seemingly random other values, always very small, while I’m doing other things. I can’t find any pattern or repeatable steps to recreate it.

I just took the attached screenshot. This is right after I set the values to about 30-70 each.

Screenshot 2024-05-08 at 11.22.46 PM


I have the gamma set to 1.75, and have been adjusting to see where it looks best between 1 and 2.5, but it’s hard to tell when then the intensity values keep changing on their own. I probably don’t understand gamma as well as I should…

Well certainly there’s no “automatically fiddle with light values” feature. It’s a bug or something, I’m just not seeing it here.

I can’t repeat that here. Values I set to lights stay put. pls run _SystemInfo in Rhino and post back the results.

Gamma has to do with mapping render colors to display colors. Rendering is done in linear space.
Since monitors traditionally don’t have a linear response to their input, gamma correction is applied to compensate. Otherwise midtones would come out darker than intended. the sRGB standard for example assumes a monitor gamma of 2.2. Images often have this gamma correction baked in. If you take a picture with a digital camera, and open it on your computer, this image already has been processed with gamma correction (if it is sRGB or Adobe RGB) and if it is a RAW image, even then correction gets applied for displaying it on your screen.

I would not change gamma from the default 2.2 unless you know what you are doing and are after a specific effect. If you are looking for a natural light response stick to 2.2. If you need to darken the midtones, lower the gamma, if you want to brighten the midtones, increase the gamma. Gamma only affects the values between black and white. In all gamma settings black and white are the same.

In Rhino rendering settings, you’ll find a setting that says linear workflow. Keep this setting on as well. What it will do is process images, to remove their baked-in gamma correction, so that they can be rendered in linear space.

Besides the gamma control there is still tonemapping you can play with - Filmic with either low, mid or high contrast.