Weaverbird for Rhino 6

I recently installed Rhino 6 but now I can’t install weaverbird,
anyone who knows if weaverbird will get updated soon?
or is there a different way to install the plugin?

It works for me in rhino 6 and grasshopper 1.0. I didn’t reinstall it. What I am sure is that many of the function of weavebird are now in rhinocommon.


1 Like

Does your gh in rhino 6 have weaverbird tab? I thought wb installs with r6, along with kangaroo.

I have that

Old plugin are working, so the solution could be to install an evaluation version of Rhino 5 and GH0.9 ??

in the previous version that I had, I had installed weaverbird and Kangaroo…
now when I open grasshopper, Kangaroo is still there (just like Lunchbox) but weaverbird isn’t there
and I can’t install it eather when downloading it from http://www.giuliopiacentino.com/weaverbird/

If I go to the component folder of my grasshopper I see the same components in there,
the only difference is that your symbols are showing where mine doesn’t

It is strange I did nothing special and I still have weavebird working in Rhino 6. GHA ow weavebird is here
C:\Program Files (x86)\Weaverbird\Weaverbird.Gh.CommonSdk.gha

Same. Must be that we have r5 still.

Hi all,

The easiest current way to get WB working in Rhino 6 for Windows (without Rhino 5) is:

  • get the new Package Manager to install Weaverbird for you
  • open the definition for Rhino 6, and let the Package Manager do its magic.



Giulio Piacentino
for Robert McNeel & Associates


Thank you very much Giulio!
that fixed the problem and I can now use weaverbird
Thank you!

1 Like

Hello, where can I find the folder %appdata%\Grasshopper\Libraries?

Thank you

just copy “%appdata%\Grasshopper\Libraries” into the searchbar of a file explorer and press enter

and then you will find the folder


Thank you!

Thank you Giulio. It worked well.

I still have Rhino 5 and weaverbird is not working.
I don’t have the file: %appdata%\Grasshopper\Libraries
How can I install weaverbird?
I see last weaverbird for Rhino 5 installed at C\Programma Files (86)\ weaverbird

Thank you,

This is a folder. You can use File Explorer to find it. Just copy-paste the folder here:

However, because you already have Weaverbird installed, you may as well just run the Rhino Command: _GrasshopperDeveloperSettings in Rhino 6 and add a new line for C:\Program Files (x86)\Weaverbird (please check exact path).

1 Like

Thank you, the last option worked well!

It is in Grashopper but I do’nt have a tab in Rhino 6. That isn’t possible?i

Unable to load plugin. The plugin does not appear to be compatible with this version of Rhino.



Yes, Wb is only now available in Grasshopper!