Wall Profile - Doesn't Consider Location Line When Creating Walls

Hi guys,

I want to create walls from surfaces that I created in Rhino. I have produced these surfaces with Revit walls, columns, beams etc. and did Solid Union operations on them.

I want to use vertical faces to generate walls. When I use Add Wall Profile and Wall Location Line as Finish Face: Interior, the generated result is this👇:

Eventhough, wall location lines are set as Finish Face: Interior, their locations are centered.

Any idea why this is happening? Revit 2022 file and Grasshopper definition is attached🔽:
Project1.rvt (676 KB)
Wall Finishes by Profile.gh (15.8 KB)

I was getting some odd results from your boolean geometry so i took a slightly different route.

Problem: The profiles curves need to be ordered and in the correct direction to get a consistent LocationLine placement.

My solution here is to use the Add Wall by Curve as an example how to get better control of placement.

RE_Wall Finishes by Profile.gh (20.8 KB)

Hi @Japhy,

Thanks for taking your time. The script you shared doesnt give me the result I want. There needs to be walls both in interior and exterior surfaces at the height of faces. This is what I get from your script🔽:


Is this what you got too? This is what I am trying to get🔽:

We are creating separate walls for wall cores and finishes. About the wall that I am trying to create, you can think of it as a plaster. I need to generate walls on column surfaces, beams and walls etc.

Btw, I realized the script I shared had one thing wrong. Fixed version is here👇::
Wall Finishes by Profile.gh (15.8 KB)

The issue with getting the wall locations exactly where you want them is with the direction of the curves you are generating. They are not consistent and would all need to be oriented relative to the desired normal direction.

Take a look a this and see if it helps, it still needs work, i was getting better results using a component in sasquatch plugin called polar sort.

Re_Wall Finishes by Profile-v2.gh (16.9 KB)

If you have pufferfish this actually works best so far.

1 Like

I also would recommend adding a filter to remove any of the Wall 2 types after they are added.

Hi @Japhy,

This method works in this particular case. But most of the time we dont really get rectangular shapes, we get some irregular shapes. Example file where the method you proposed doesn’t work is attached. I believe some improvements needs to be made about Add Wall (Profile) node itself.
Irregular Plaster Surfaces.rvt (644 KB)

This is a common issue in Rhino/Grasshopper. You have to control the order and directions of curves coming from breps and surfaces, especially as you go around a building. Setting up a way to get the proper plane orientation is the place to start, then you can create consistent geometry.

Something like this might work.

image

Nope, this doesn’t work as well. Still same, walls are created from centerline eventhough their location line are set as finish face interior.

I think this shouldn’t be that complicated. If someone from the team would take a look at it. @kike @eirannejad

Its placing it on the finish face interior, the curve direction coming from you solid union isn’t going to be consistent though.

Eventhough it sets wall location line right, it still creates walls using wall or core centerline. Their location is wrong, that is the issue. And I have checked whether if something is wrong with the Solid Union result and it look just fine. I have added a brep direct shape using resulting faces’ normals and they are all facing to correct direction. You can see it below.

We are both correct actually.

I think the easiest illustration is to bake the curves into Rhino, select a curve and type DIR. This will give you the curve Seam and Direction. This is going to be used by Add Wall to Curve Component for orientation.

if i use the flip command (or option after DIR) it will reverse the curve and placement of the wall… if it was placing per the Location line, which its not.

My apologies, I didn’t get past the curve issue to see this, the curve directions is still a factor but this looks like a bug.

1 Like

I think it should be a bug or something else.