Vray environment background won't save with image

I have a scene with an image set in the Environment background slot of the option editor tab.
The model renders and displays fine in the VFB.
But whenever I save as png, I get a transparent bacground instead of the background image. If I save in another format, the image is complete. Where the heck did the background go ? I like the png format but I don’t see a choice for invisible or visible background.
When I use a dome light instead and place the environment image there, I have no problem saving as png. But if I use the environment background option I get this problem.
What am I missing ?

Juan, my guess is it’s because you have an alpha channel being rendered. If you go to the VFB Channels tab in the options menu then make sure to un-check the alpha channel then it’ll save out ok (but you’ll have to re-render obviously).

The reason the dome light saves out ok is that it’s considered as geometry for the alpha channel.

I get that but if I save as tif for example, it saves everything including the alpha channel and it displays correctly.
I rarely use the evironment background as I prefer to use a dome light which gives better results in terms of better shadows for example.
But I’m trying to set up a scripted method to batch render associating each saved view with the sun orientation and the environment rotation and I can’t find a way to access the rotation of a dome light map whereas with the evironment I found some code by the folks in chaos group to rotate it

Mmmm, the VFB is pretty screwed up in my opinion, I see your only option is to switch off the alpha channel. Do you really need it?

Not all the time, it depends on the view. I’ll have to do that I guess.

This may be too late, but I found a solution as I was having the same issue. It can be found in this thread on Chaos Group Forums.


Originally posted by Raven
Hi Palosanto

If you want to remove the alpha and see the background in photoshop do the following.
Open the image in photoshop.
go to the Layer menu -> Layer Mask -> From Transparency.
This creates a new layer mask.
Now delete the layer mask in your Layers panel.
Your layer should now have no transparency and you background should be visible.
It is one of the tricks with image formats that don’t use a separate alpha channel, but rather transparency values for each pixel."


Hi Emmanuel,
I actually found your solution eventually although I can’t remember where …
Thanks anyway