Sky background not visible

Test render outdoor scene: Vray 5/Rhino 7.
Why does the rendered scene contemplate the blue of the sky, but the saved image (png file) erases the sky and sets a white background?
Could someone help me? maybe in the Vray panel you need to set something?

Try saving as a JPEG.
For PNG you need a dome light.

I’ll try, thanks. :wink:

I forgot to ask if you have dropped a Vray sky texture in the environment>background texture slot (it’s on the page with camera, render output, etc) and set up Rhino Document Sun?


1 Like

Two other ways:

  • use the free image browser XnView - you can enable/disable the alpha of a png and remove the alpha, so that the background is visible again

  • in V-Ray you can set an output path and disable the alpha, but all images will have the same name.


It’s a pity that the developers was not able to allow to simple render without alpha, I miss it often too.

1 Like

Saving from VFB manually will always output an alpha channel. It is a separate component, and it currently has no option to not write the alpha out. RenderOutput is the only way to remove the alpha

Thank you all.

I checked in the Vray 5 control panel.
I can’t see all those options regarding the alpha channel:
Immagine 2021-05-05 095534
“Image option”, where is?

you have to put a file name. The file name extension will determine the kind of the additional options to show

1 Like

Ok. Perfect! :+1: