Vray complaints

I want to ask users here what is their opinion about Vray. *Vray 5 on R7

My experience is that it is so full of bugs that it is impossible.

Textures dont display properly, they either go black suddenly very often or materials show as white in rendered view and only manual unticking and ticking of diffuse layer brings the texture back.

Other issue is with cosmos assets which just dont appear in the render even though they are correctly loaded in the scene.

It is a nightmare for me. Untolerable. Just a waste of time and money.

1 Like

I use V-Ray since many years and I use V-Ray 5 and Rhino 7 all days. I’m happy and use it for living. It’s a powerful tool. I don’t see your texture problem here. I don’t used Cosmos assets in the last time, but keep in mind it’s a young addition so maybe there is a bug.

I see no alternative for VfR on Rhino. If I run in problems than I try to help to get all bugs fixed and send scenes per email to the support.

I know this post doesn’t solve your problems. Only I can say - VfR is it worth, also if something shouldn’t work at the moment.


1 Like

any chance your graphics card is underpowerd or has drivers out of date?

please run systeminfo in rhino and post the result-

I believe both problems comes to moving the model file between different machines.

There are two indications that the Cosmos Assets links are broken. The red tick in AE and the lack of geometry in the render. Most probably the database is missing the exact asset revision. Having the cosmos model files on the disk is not a guarantee that it would render. These files by themselves are useles. They are missing essential metadata, that is fetched from the database, and then the entire asset becomes renderable.

The white textures are due to the fact that Rhino does not understand the .tx image format V-Ray library materials use. So we convert those files to low-quality temporary .jpg files, which Rhino OpenGL pipeline can handle. We use the standard Windows codecs for that. I guess either there is a bug somewhere convering the files, or the Windows codec is playing tricks ( not the first time this happens), or it is some edge case related to the moved model files.
Anyway we are going to ditch the .tx converter in favour of the core texture sampler soon. This will make not only .tx files but also the procedural textures visible in the viewport. Btw Rhino is using the same approach to display its procedurals in the viewport.

In any case it would be interesting to debug both


I had known vray for long so i just bought it without testing because i trusted it but after almost a year i have been having issues non stop.

i like the software and its features if only it worker correctly.

as Nikolay mentions below my issues are definitely related to working on more machines on one file stored in cloud.

thank you for the insight

yes i see the red tick next to my assets but there is no button to click to resolve nor any warning that something is wrong with options to do something about it.

i have my files on google drive and i access it from more machines. its no novelty and i cant imagine companies access one file with one machine. its non sense prerequisite to follow so that things work properly.

there have already been two updates to vray5 and this still has not been adressed and it is a deal breaker for me because in my eyes it simply does not work (no minor issue).

Hi. I think the root cause of the problems are due to reasons desribed by @Nikolay
I have tried it on 3 machines with different specs and latest drivers installed. It is the same on all of them.

Yup, we must enhance that part for certain.
V-Ray uses full file paths. Always. That is mostly because film studios use fixed production pipelines on each machine. And that is where the V-Ray roots are.
There is bunch of code atop that tries to handle relative paths one way or another, but sometimes edge cases do occur.
Reporting it properly as soon you encounter it is the only chance it would be fixed

this is the model

First things first: Materials

The file you sent does not contain any V-Ray material !. I opened the file with pure Rhino - no V-Ray plugin loaded. I expected to see all V-Ray materials as “Placeholder” type. However all of them are “Custom”. From the names and properties I can tell that they were once V-Ray materials, but were converted to Custom materials on purpose.
As I said Rhino can’t handle .tx files, so it simply falls back to the default white plaster color. That’s why everything is white in the viewport.

here is the evidence - you can see the material type is “Custom” and the diffuse color is a .tx file.

This was once a V-Ray material, and if it stayed like that we would generate that low-res .jpg if it is missing. It is the same with others

If I enable V-Ray and open the file I get this message:
It appears because of 3 possible reasons

  1. The types of the materials have deliberately been changed to non “Placeholder” while V-Ray was not loaded, and further modified them

  2. The model was opened without V-Ray being loaded, and then saved again. Then upon further opening you might have got all “Placeholder” materials duplicated as “Custom” materials automatically. For some other reason the original placeholder have further been deleted.
    This is a Rhino issue: https://mcneel.myjetbrains.com/youtrack/issue/RH-66599 and has been fixed in 7.13

  3. The model was opened without V-Ray being loaded, and then the V-Ray plugin was loaded manually (either double clicking on the V-Ray item in the Rhino plug-ins dialog, or used the “install” button there). Then you’re running into another Rhino issue: https://mcneel.myjetbrains.com/youtrack/issue/RH-66913
    All plugin materials will be broken if you save the file. The issue is fixed in 7.15

  4. The model was opened right after V-Ray was installed, with double click from explorer. This is rather a manifestation of #2. When loading a plugin for the first time, Rhino does some caching. AFAIK when double clicking that caching does not occur and the model gets loaded before the V-Ray plugin. I strongly suggest after V-Ray install (or any other Rhino plugin), Rhino is started, without opening file directly (no double clicking on a file or no drag-drop on its icon). You will see a popup “Rhino is loading a plugin for the first time”. When that goes away, you can open your file, the way you prefer.

If none of the above happened, then one of those might be the case:

  1. You have either attached a wrong file, where it did happen
  2. There are more auto-material-conversion bugs with Rhino that I don’t know of
  3. You have gremlins in your office

From my and Rhino perspective everything with the file is OK. All materials are “custom” materials, some of them have unsupported texture types.
There are number of leftover V-Ray materials in the Asset Editor that do not match Rhino material panel, which is an indication that the Rhino representation of the V-Ray materials have been modified without V-Ray being loaded.

@Micha can share more info (incl. forum posts) on these kind of problems, since he was first to discover all that with one of his clients.

Yes yesterday i opened the file without vray loaded and saved, i got the prompt about disconnected materials and hit rename (i hoped that would preserve vray data). But my originally described issues had happened even before when it was not the case (when materials were still vray).

Now i am checking my model and all the materials are custom instead of vray as you show. Hmm i was not aware opening the file without vray will destroy the file basically. As you say it might be Rhinos issue.

I tried third machine yesterday without vray and saved. I would not have done it now when i see everything is gone.

@Nikolay Now I got the disconnected material issue at a file which wasn’t opened since October last year, as it was working fine. So maybe, additional we have a bug. It could be caused by a Rhino or V-Ray update. Please check support ticket #20697, I sent fresh info today. :wink:

My final remarks are that obviously there is something wrong when it is so easy to mess up your model unknowingly.

This should be much more robust. Opening file without vray installed must not mess up the model. Other problems should occur just sporadically not by design.

Just to make things clear.

  1. It is OK to open the model without V-Ray, just don’t edit the V-Ray materials (don’t change the type).

  2. V-Ray or any other plugin, cannot change material types with code. There is no such API in the Rhino SDK.I don’t know what caused changes to the material type (going Custom), but it is either Rhino (those two bugs, or more), or a person.

  3. The “rename” option in that window will keep the V-Ray data in tact. But the material assignment was already gone. You just need to assign the “whatever_recovered” material to the objects having “watever” material, and delete the “whatever” material.
    As in 2) there is no API in Rhino to swiftly replace material assignments.

  4. The V-Ray materials are not really connected to Rhino materials. In fact the V-Ray materials in the Rhino panel are our own custom Rhino materials. It is nothing about “connecting” or whatever. What looks like a connection is in fact deletion of the existing material, creating a new V-Ray custom material and change the material assignment of the objects having the first material with the new material. As you can see the third part is pretty impossible to implement without years of bugfixing. That is why there is no option in that dialog to reassign, but only to delete and rename materials.

Ironically, when going between machines with Cycles, I just dump the files in a folder on Dropbox–and go.

Cycles integration is done by McNeel. There isn’t a Cycles material, nor unsupported textures. There is no fur, mesh clipper or mesh lights, nor even spherical lights. Plus its integration has access to the core Rhino code.
No fancy stuff at all. It is not quite the same

1 Like

Thank you for the answers.

This is it that i did not

I suspect this could easily be Rhino´s fault since i opened it in version 7.13 and after that i updated to 7.15.

I see now how materials went spoiled in the model but still cosmos models should work (this is on vray most likely).

In overall i sense there will still be problems down the way unless there is more integration of vray and rhino on more basic levels of code (lacking api to some neccessary operations).

I’ll get into that on Monday, and report here. Have a nice weekend


1/29/2022 1:32:58 PM Error [NeUI Main] SyntaxError: Unexpected end of JSON input
at parse ()
at t.Try (C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\vrayneui\resources\app.asar\main.bundle.js:1:245392)
at C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\vrayneui\resources\app.asar\main.bundle.js:79:1735025
at Generator.next ()
at f (C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\vrayneui\resources\app.asar\main.bundle.js:79:1734371)
at n (C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\vrayneui\resources\app.asar\main.bundle.js:79:1734574)
at processTicksAndRejections (internal/process/task_queues.js:89:5) {
message: ‘Invalid or incomplete version data: Unexpected end of JSON input’
I got this error Today after updating Vray


This is the error, but what did you do to raise it ?