How do I export my rhino file with vray materials to another computer?

unhandled

#1

I am building a rhino 5 model with vray materials.

when i transfer this model to another computer, it doesn’t save the vray materials (obviously because the materials are not in the same computer).

But is there a way to transfer this very same model to another computer where I don’t have to reapply the materials again?


#2

You have two options, depending on whether or not you have texture maps.

  1. If you don’t have any texture maps, then the V-Ray materials will automatically be saved with your Rhino .3DM file. You probably already know this.

  2. If you do have texture maps, use the command ‘V-Ray → Pack Scene.’ This will create a zip file that includes your Rhino file and all V-Ray textures, even if they are on a network or multiple computers. It works great, even if you need it just to get organized.


#3

when doing the 2nd option,

does that mean when i transfer my files to another computer, should it be in the same folder? and will I have to reapply the materials, or will rhino automatically update the materials?

goal is that i don’t want to reapply and re-scale the materials when i spent all that time in the first setup. Don’t want to do it the second time


#4

just experimenting.

and found that you have to unzip all the “packed” materials to be in the same folder as the rhino file and it should automatically update the materials and keep the scaling of things.

I guess i’ll deal with this method


#5

First, Unzip the newly created folder onto the new computer. Then, V-Ray will always look in the current Rhino file folder (and sub-folders) for all texture maps upon launch. Once it finds the maps, then the material are automatically updated in renders … with no further action required.

As a general rule, I recommend you do this manually anyway. I always put any V-Ray texture maps needed in the same Rhino .3DM folder. Later, I can simply copy / sync / move the entire project folder to any computer I want.


#6

Hi, where am I typing the command ‘V-Ray- Pack Scene’?

Thanks.


#7

V-ray is a menu item. Pack Scene is the command.[quote=“Mike_, post:6, topic:27384”]
where am I typing the command 'V-Ray→ Pack Scene’?
[/quote]

It’s not a typed command.
(Otherwise I would have said type ‘xyz’ into the command line, which is the only place you enter commands.)

  • Its accessed via the top menu.
  • Look for V-Ray, then go down until you see ‘Pack Scene.’
  • Click it.

#8

Ok, I have V-Ray 1.5. I guess that’s the issue.


#9

Yep. See if you can update. Most of the updates (and extras like Express Materials) have been free.

Go to Chaos Group and make an account.Look at the ‘downloads’ section where all of the updates and extras are located.

If nothing is showing up, then ask tech support. They are great at fixing things fast.


#10

hi, i have used the pack scene option and have received all my material in a zip format but i can’t see any of my rhino file ???


#11

I just tested the command and it works. There should always be the Rhino file AND texture maps, all together in the same zip file. Maybe give it another name – and then make sure you’re not looking at another folder with a similar name?

EDIT: I am not sure if you are saying there is no Rhino file in your ‘pack scene’ zip (my assumption) or no materials in your Rhino file. Please clarify.


#12

Its actually my rhino file ,I can’t see my rhino file to access my model inside the zip file which was created, is there any other way to transfer my model with the materials to another system,and ya my actual rhino file size is nearly 3GB but the zip file is only 45MB


#13

Something is definitely wrong if a 3GB file can be compressed to down to 45 MB. That tells me there is a lot of repetitive elements / empty data / possible corruptions.

Try cleaning the Rhino file.

  • Turn on all layers and ‘Unhide.’ There could be a lot that is hidden … or on layers turned off.
  • Delete any layers / geometry / blocks you don’t need.
  • Make a new file with ‘File → Save As’ or ‘Save Incremental.’
  • Use ‘File → Save small’ to get rid of all of the viewport meshes. This can make the file 50% smaller easily.
  • Now try the ‘Vray → Pack Scene.’
  • Open the zip file and see what’s in there.

Other people like to do the copy-and-paste technique. That’s where you copy all of the Rhino geometry … and then paste it into an empty Rhino file.

Try these ideas and report back…


#14

thanks a lot its working :slight_smile:


(Miguel Villegas Ballesta) #15

I tried the “Pack Scene” on a verz messy file I had, to try to gather things and tidy a bit but to my surprise when I unpacked A LOT of the textures were not in the zip… ever experienced this?


#16

Hi,
whats about V-Ray 3.0 for Rhino, i can’t fine Pack scene !!
Any ideas ??


(Andrea Montis) #17

If you can’t pack the scene , the issue is in one or some materials.
often the issue is the path of textures.

if you have a texture in a subfolder or sub folders with the same name one inside the other… take a look at your textures path :wink:


(Marc Gibeault) #18

You’ll find the three related commands in the V-Ray menu (V-Ray item in Rhino’s menubar)


#19

Thank you.


#20

Thank you, Found it.