Visualization problem in perspective view

Hello everybody,
I have been working with this file for a while and never had any problem visualizing it. At a certain moment, though, I started to lose the image when zooming in. It looks like it’s not possible to go back.
If I set the display view as Parallel I can finally see the objects, without losing them when zooming in, but clearly the the shaded mode doesn’t work properly.

Does it depend on the graphic card, or should I download some upgrade?
I have a 4.0 SR9 version.
This are my graphic card specs:

…and here are some screen captures:

shaded mode, perspective view:

shaded mode, perspective view, zoomed in

shaded mode, parallel view, zoomed in:

This is Rhino and not your video card. The bounding box of your entire model is likely very large. You may want to run the boundingbox command to see if there is a piece of geometry that is vary far from the other geometry in your model.

We do a much better job of handling this case in V5.

1 Like

Thanks for replying so quick!
So I have done the boundingbox operation and got rid of the far away objects. then even purged but the problem is still there.

could it be related to the amount of objects in the file?
the current file size is 200 MB.

I tried to export only few objects to a lighter file (31 MB), but it doesn’t seem to help.
what can I do?

Hi Giulia Pastore

I think it more likely to be a problem with geometry size rather than file size.

Try this in a disposable copy of the file:

First see what happens if you center the model around the world origin.
So move the approximate center of the structure to the center of world origin (0,0,0)

If that does not help see what happens when you try and scale the model down by a factor of 0.001
to effectively scale down to meter distances. How does the model react and display then?

-Willem

Since a couple of days quite often my perspective view goes blank, it looks like a camera clipping problem like i’ve seen in Maya. I have not by knowledge changed any settings of the camera, but it never showed this behavior before. It happens like this when zooming in/out, but it also just disappears from time to time.

It looks like the same problem as this one. I’m running R5 SR6 64-bit (5.6.31028.18305)

The file is in small objects - milimeters.

In other files I can just fly through faces, zoom in/out without losing geometry like this.

Hi Peter- the camera and target are in almost identical locations- Zoom Extents should fix this, I would think.My guess is that you mouse-wheel zoomed until the camera closed right up to the target. In case it helps, I generally always use Zoom Target in prefernce to Zoom Window- it helps avoid this kind of problem. Let me know if that does not sort it out.

-Pascal

Yeah I expected that would cause it, yet I have tried zoom selected, and other zoom options to try to fix it, but strangely enough for that spring (or it’s location in the scene) it keeps occurring. I’ve continued working on the model and am not experiencing it in other areas.

Hi Peter,

Is there other geometry in the file? Might it be located far away from the spring?
Can you save/export just the spring, and duplicate the same problem in that file?

Is this just a pipe and a curve with 2 points, or is there some other type of geometry involved?

-Willem

It’s a spiral/helix with a cruve sweeped over it. I’ll check if the spring has the same problem when I come across it again.

Hello,

I have this same problem very often, when I zoom in near an object some objects that are far away from the camera dont show up properly.
Scaling the model does work but for obvious reasons that isn’t the best solution.
I am working with a very large topographic surface in V5.
Any suggestions?
Best regards.

  • Santiago GL