Perspective view cuts model

my rhino started to make an odd thing while in perspective view and zooming in inside the model.

it wont show any metarial that it cuts with camera
this happened in 2 diffrenet computers and sevrel diffrent models.

Hello - does a shaded viewport show the same problem? And a full rendering?


it does the same in shaded viewport
render works fine.

I see, thanks - we’ve had examples of this sent in, one of which I am looking at now and the problem does not show up in that file in our current build - yours looks like a large and complicated model - is there any chance we can get the file from you (, with a link back here in your comments) , or a simpler/less confidential one that shows the problem?


This happens in two diffrent computer with all my models.
its like the camara settings in both got changed by somthing and i dont know how.

i deleted rhino settings and started a new super simple project.

this still happens.
its like when the camera “inside” the wall then instade of solid it shows as wireframe

Hello - can you please run the SystemInfo command in Rhino and copy/paste the results here?


Rhino 7 SR7 2021-6-9 (Rhino 7, 7.7.21160.05001, Git hash:master @ d2161989109d5dacba531310b5d345ce6f4da9f6)
License type: Evaluation, build 2021-06-09
License details: Cloud Zoo
Expires on: 2021-09-30

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 3-8-2019 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce GTX 1660 Ti (NVidia) Memory: 6GB, Driver date: 6-21-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 471.11
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-21-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Users\eliho\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.21124.1031

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hello- a couple of things to try - one is to disable Enscape in Options > Plug-ins page and then close and reopen Rhino and see if anything is different. the other is to look in the NVidia control panel for a setting that forces ‘High performance’, so we can be sure the NVidia card is working and not the 630. It probably is, but just to make sure.


i uninstalled enscaped and pushed the graphic card to the maximum and still no good.
losing my mind this is my final project for my degree and nothing seems to work.

Hello- in your example above, the plain box displays correctly until the camera is inside the wall, is that correct? That last is expected, btw, but that is not the same problem as your original post - I would like to see an example of that.


this is the situation now after all the steps

@elihoabadi123 - it looks like your upload failed - please open the file, SaveSmall, and then zip the resulting file and try again.

@elihoabadi123 - I have your model - thanks for doing that again - there is no named view that looks like it corresponds to what your screen shots show. So far I am not able to find a view that clips as you show.
You might also do better if you hide the terrain for views where that is not visible to reduce the scene’s dimensions.


morning, thanks for the replay.
i just sent another file with perspective 7 shows the problam.

Hello- I am, again, having trouble getting the files from our server - can you please try the second method you used yesterday? That worked.

Did you try hiding all the terrain and distant objects for the close-in views? You can use Snapshots for setting up various scenarios for each shot.


@elihoabadi123 I see the problem in the last file you posted. My earlier suggestion of hiding a large part of the model seems to fix the problem here-

You can see that the camera is very small compared to the overall extents of the scene if everything is showing and there is a lot of geometry behind the camera, which tends to be a problem, I believe, too.


O wow your a life saver.
I will try those staps soon when i get back home.
Can you please send me back the project fixed? if it os not too much to ask.

בתאריך יום ו׳, 9 ביולי 2021, 20:30, מאת Pascal Golay via McNeel Forum ‏<>:

Hello - I can send you the file, but you should be able to fix it yourself - can you try turning off the Environment layer and hiding other objects that are far outside the visible scene? I think there are some curves and so on. Does that do it or no?


Yes i will try but in few hours since i am not home atm. I will keep you updated.

בתאריך יום ו׳, 9 ביולי 2021, 21:06, מאת Pascal Golay via McNeel Forum ‏<>:

hey pascal, thank you very much for the help.
looks like the camara and the enviorment solved the problem.
however it still shows a bit “cut” so i was wondering if there is a command to reset camara settings.5

once agian thank you.