Perspective Viewport Issues in Rhino 7 (Mac)

I was working on a model, when I went to zoom in very close on a small naked edge, the Perspective Viewport stopped responding. When I went back to 4 viewports and select something and Zoom selected for all 4 viewports, the Ortho views all respond as expected, but the Perspective viewport shows nothing (in wire display mode, ghosted, rendered) and I get this:

“Unable to zoom some views - no objects are selected.”

I tried copying and pasting the contents and if I tried the whole file, the new file had the same problem. If I copied and pasted only selected items that new file seemed to be fine. The file is almost a Gig, so I don’t know if that is/was a factor, it’s just weird because because the rest of the file all seems to work fine, no issues, just the perspective viewport. Even if I go to “set view” as change to Top, Right, etc. that one viewport just doesn’t do anything. I can change the other viewports to perspective and that works, but in 4 viewport mode, the top right square is just dead/blank/grey like it would look like with no geometry.

zooming in super close can cause issues when you try to view small issues.

the fix is to select the problem area and then use zoom selected.

the only condition to that is if the model is a long way from the origin. If it is, simply move it to the origin.