Perspective viewport problem (again!)


#1

I have not seen this problem in a while since Version 4, but it just came back with a file that I haven’t opened in year … I researched the issue and here is the problem, followed by what I tried.

PROBLEMS :

  • the shaded perspective viewport will show sections that are
    wire-frame / ghosted or edges that should be blocked are visible.
  • I have camera clipping, which will make nearby geometry disappear
    when zooming or moving.
  • I also have the entire model disappear when in an orbit. Certain
    angles are OK, a few degree of rotation and Hey! I’s gone.

TROUBLE SHOOTING Things I tried, but didn’t work

  • zoom selected
  • with F6, I can see the camera and target. The target is far enough
    away
  • refreshshade
  • select bad objects (none)
  • reset all four viewports
  • reset perspective camera
  • verified that the model is on the origin / no objects far away / visible or invisible
  • verified that the video card is on ‘workstation / streaming’ mode
  • video card has current drivers / also closed & re-booted
  • running rhino 5-64 with SR 8

I am running and nVidia K4000 on Windows 8.1 - 64, but all other files have been fine.


#2

I made a four minute demo video so you can see the problem (and not have to read as much!)

Video link

Other files are not having this same problem, so that has me thinking that there is a corruption in the geometry or file, but it is not turning up in any of the usual analyses. I did notice that my tolerance is set to 0.0001 mm, which is higher than I normally use, but I am not sure if that could affect the display.


(Pascal Golay) #3

Hi Dave - if this is file-specific, please send me one that shows the problem or send to tech@Mcneel.com. My guess is there is some object or even possibly a control point located in ‘outer space’

-pascal


#4

Is there any way to set the camera near clipping? I see this is where your file messes up, when it suddenly moves past the clipping, and that clippingplane in your video is “jumpy”.

So I would guess an object causes this.

I would trouble shoot this by hiding one and one object until it doesn’t happen. And are there any blocks in the file with an insertion point far from the object(s)?


#5

Pascal

Thank you, I will send the file soon. How do you recommend a file transfer?

UPDATE / FYI:
This file was originally created in Rhino 4 / VRay 1.5 / Bongo 1.0.
I am now running Rhino 5 / V-ray 2.0 / Bongo 2.0.
I just did a manual re-build of the file and copied and pasted all the geometry. So far, its OK, but I am still in the early stages of re-applying every single material.


(Pascal Golay) #6

Hi Dave- you can get the file to me, pascal@mcneel.com or to tech@mcneel.com via http://www.rhino3d.com/upload

thanks,

-Pascal


#7

Hello @Holoo

Good guess, but there were no blocks in the file. The copy-and-paste / re-build hacks SEEMS to be working for now, but I am very curious how this happened, so I’m sending the file to Pascal for review.


(Pascal Golay) #8

Hi Dave, also, -SaveAs (dash version) with ‘savePlugInData=No’ and see if rhe resulting file behaves better- if so, that will be a pretty clear indication that a plug-in is to blame, and not distant geometry.

-Pascal


#9

Hey Pascal

I was out of the office for a few days, but I just got back and did your test. It worked AND the problem appears to have been Bongo. (Or a conflict with the other plug-ins)

If I remember correctly, I started this file with ver 1.0, tried ver 2.0 when it was in beta, and then upgraded to ver 2.0 when it was released. I turned off Bongo, re-started Rhino, and the problem disappeared. Also, this file was started with older versions of Rhino and V-Ray as well.

I have since re-built the file from scratch using copy-and-paste geometry, so I’ll continue with that process. It wasn’t too bad. I’ll report back if the new file has any problems with Bongo 2.0, but it will be a while until I am ready to animate.

Thanks for the help!
Dave