VisualArq regenerating graphics triggered by certain commands


Recently I’ve been having this problem where certain commands, MoveFace, SplitFace, ExtrudeSrf (once in a while) seem to be triggering a VA graphic regeneration. A loading bar appears on the bottom right of the screen and this could take up to 30s to 1 to 2 mins, a lot longer than the refresh all VA objects command, and is extremely disruptive to the workflow. The objects which I am manipulating in the file with those commands are not VA objects. I was wondering if there is a solution to this issue?


Hi @enquiry,

Are any wall extended to the objects you’re modifying? If that is the case, then it’s normal that VisualARQ triggers a graphics regeneration.

What is not normal is that it takes so long, or more than updating all VisualARQ objects, so there must be a problem or bug.

Can you send me the model to so I can take a look? Please, let me know which objects do I need to modify.



Hi Enric,

I’ve dropped you a mail.


Hi Brian,

There are some section view and plan views in the model., although they are inside hidden layers.

Section and plan views could be very slow, specially on models with many objects like yours (there are thousands of lines and curves). If for any reason they need to be updated (because you move the view or you modify the section line), it could take some time, as the update will take into all visible geometry.

Since VisualARQ 2, you can use real-time section and plan viewports and details, which are real-time, and there is no need to manually update them.



Hi Enric,
Does it run automatically also in va-2.8.2 ? I am working on 680 Mb file includes 6 plan view and sometime they starts to update, however I didn’t change any va-object or element neither I run the Update command. and of course it takes so long. Do i have to do any spec. setting to avoid or stop it?
it also happens when i modify rhino dimension style however have no dim on the model.

Hi AKD, these objects have texts (their title) that use Rhino dimension styles, for that reason they update when you modify these dimension styles.
Uncheck the “Auto Update” option of 2D Plan and Section view objects to avoid updates in incovinient moments. That way you will control when you want them to update running the vaUpdate command. image

In any case, as Enric mentioned in the previows post, it is recommended to use real-time section and plan views of the model for 2D drawings, using the Hidden display mode, that will let you print what you see directly to vector output, and save you from adding tons of extra 2D geometry in the model and caring to keep them updated. (