Rendre l'affichage plus rapide

(jmv) #1

Hello,

I would like to know if it is possible to disable the VA display process ?

With this scene :

there are not many elements, it’s still a small project, but to show and hide the objects takes 6 to 8 seconds. And i’m a good computeur (win10, GTX1080, RAM 32Gb, etc)

Is it perhaps a process to hide the tangent edge between the walls? Personally, it does not matter to have a pretty display for editing.

If possible, I want to disable this feature and only have the Rhino display.

Thank you !
-jmv

0 Likes

(Francesc Salla) #2

Hi jmv,
When you hide or show a VisualARQ object, VisualARQ regenerates the objects that are intersecting or involved in that object. This may cause the slow performance. We are studying how to improve this behavior.
Could you send us that model to visualarq@asuni.com just in case there was another reason of this slow performance when hiding objects?

0 Likes

(jmv) #3

I sent you the file.

So today, it is not possible to speed up the display process by disabling an option(s) ?

Thank you for your help

0 Likes

(Enric Marquès) #4

Hi @kitjmv,

This is not a display issue. The problem is that when VisualARQ receives a notification that an object has changed, all interfered or related elements are recalculated, just in case the change may affect them. The problem is that hiding or showing an object is a change, so we regenerate some geometry. We should check what has changed in the object, and avoid regenerating elements when the change does not affect the interfered element.

Enric

0 Likes

(jmv) #5

Ok, thank you @enric. I understand.

At the moment, I’m trying to not using _Hide, _Show or _Isolate anymore, but hide or show the layers, there is no regeneration with this alternative

-jmv

1 Like