Elements from levl below are appearing in the next level

Hello everyone,

I am having 2 issues where elements from level below are showing in the level above plan and some elements I wanted to show in the level plan doesn’t appear, such as ceilling lamps that in order to show up I needed to move the lamp models down so it could appear in right level plan.

What am I doing wrong?

In the images, green is for the objects from the 1° floor appearing and purple the 2° floor appearing in levels above. Also, other elements that were not in the ceilling such as sinks were appearing too and is not in the image because I deleted it before needing to come here ask why this is happening. But if you take a closer look, in the first image you can see the sink i am talking about under the fan circled in purple at the left side and this sink is from the fist floor.

Also, spaces are not showing up in any plan I make.

Images showing the elements from the 1° floor appearing in the 3° floor and the spaces that won’t show up in the plan.

This is the roof plan, and it shouldn’t have any of those elements.

Hi @Leonardo_G_Pate this looks like a bug. Can you share that file so we can check it out? What VisualARQ version are you using?

I am using VA3 Beta… the file is very big so the file and templates (.val) are in the folder link below… You know why spaces are not appearing in plan views?


Thanks @Leonardo_G_Pate I’ll let you know when we fix these issues.

the space not appearing is a bug aswel???

Yes, that’s a bug as well.

1 Like

Hi @Leonardo_G_Pate the issues of the space not appearing in the plan view and the Element objects 2D displayed in the wrong level have been already fixed. You can test it out in the current Beta 6 version.

beta 6 is only working with 8.7, not 8.8… do you know why?

Hi @Leonardo_G_Pate,

I have tried downloading the latest version of Rhino 8.8 release candidate (8.8.24149.15001, 2024-05-28), and VisualARQ 3 Beta works perfectly.

What error do you get?


I cannot even install it

Your Rhino 8.8 RC is not the latest one.

I don’t understand how is that you have a release candidate of Rhino 8.8 while your are in the “Service Release” channel.

Rhino 8.7 is the official public version, while 8.8 is in release candidate. Please, downgrade to Rhino 8.7 or update 8.8 to the latest build (May 28th).


so this specific build I have cannot load visualarq beta 6?

VisualARQ 3 Beta 6 installer looks for a Rhino 8.7 or greater, so in theory it should work. Maybe your Rhino 8 registry is corrupt, and the installer cannot deduce the installed version.

I tried to install Beta 6 on the latest Rhino 8.7 SR and latest Rhino 8.8 RC and the installer ran fine.

Can you try to repair your Rhino 8 installation? You can do that by clicking in the Rhino 8 “Modify” button in “Add or remove programs” Windows settings.