VisualARQ 2 - Version 2.13.1 released


VisualARQ 2.13.1 is now available for download.

This is a minor release that solves most of the critical issues and crashes reported by users. Please report any problem or suggestion here or send us an email to

Here is the list of changes:


  • Grasshopper: Components:
    • #10304: Identify VisualARQ objects through ID
  • Object: Section:
    • #12626: Place the Construction plane coincident with the section plane when clicking on the “Align view to Section” option


  • API: Script:
    • #12624: Methods to define section attributes are not working
  • Display:
    • #12672: “Shadow ignore user defined clipping planes” option is not considered in plan projection
  • File:
    • #12709: Error after saving a dwg file as 3dm
  • Object:
    • #12685: Disable “Snap on occluded objects” doesn’t work with Hidden display mode
    • #12647: Disabling “Snap to occluded objects” option does not work on VisualARQ objects
  • Object: Beam:
    • #12687: Beams need to be manually updated after scaling
    • #12686: Beam alignment offset doesn’t change automatically when multiple beams are selected
  • Object: Curtain Wall:
    • #12673: Curtain wall frames are not visible in plan view
  • Object: Stair:
    • #9765: Stair numbers remain visible even when stair is partially hidden
  • Object: Views:
    • #12038: Print Width is not displayed on the geometry in Plan and section views
  • View:
    • #12742: Overhead representation of furniture objects in the wrong level

See the list of changes of VisualARQ 2.13




Seems like this update may have broken dimension lines in layout space. I can’t seem to get dimensions to snap to VA Walls in layout details. Windows also are invisible to dimensions. Other objects appear to be unaffected.

Hi @Clayton_Muhleman that’s weird. Snapping dimensions to walls in page layouts works fine on my end. Can you provide some file, screenshot or video that helps us to figure out what’s happening?

Hi @fsalla! Thanks for the quick reply, but I’m afraid I’ve blown a false alarm.

Turns out I somehow turned off “snap to occluded objects” in the Osnap settings. My guess is I’ve had that on forever, but never noticed because that didn’t work with VisualArq objects until you fixed it in this patch. Mea culpa.

Patch is fantastic, thanks for all your work. I had an architect colleague (Revit user) over to the office this morning to show them the work we’re doing with Rhino and VisualArq and they were blown away. Thanks again!

Hi @Clayton_Muhleman,

After some testing, I have found some bugs in VisualARQ 2.13.1 (most of them occur also in VisualARQ 2.12 and 2.13, so they are not new):

  • Snap to VisualARQ objects on a non-active detail does not work.
  • Snapping to section lines of VisualARQ objects (like walls) in an active detail does not work.
  • Snap to sectioned parts in an active detail works, and it should not.
  • Snapping to visible lines occluded by sectioned parts of objects does not work if the “Snap to occluded objects” option is not enabled.

And there are other problems as well.

I have been working on a solution today; and it seems that now all cases are handled correctly. I will carefully test the fix, and tomorrow I will release a preview version of VisualARQ 2.13.2.

Thanks for reporting the problem.


1 Like

Hi @enric,

Being able to turn off occluded objects and directly snap to sectioned lines would be a huge quality of life improvement, not just for dim lines, but working in details and sections in general.

Thanks for spending some more time on this issue!



Hi @Clayton_Muhleman,

Here is a preview build of VisualARQ 2.13.2:

Snapping should work fine on VisualARQ objects in model, layouts, active and non-active details, with “Snap to occluded objects” enabled or disabled. Snapping to section lines on VisualARQ objects should work too.

Please test and let me know if it works.



1 Like

Hi @enric,

I’m happy to report it works great. Overall stability of dimensions and snaps in details has improved. Less jumping around during selection, obscured objects no longer are selected, dimensions seems to be less likely to teleport off the screen. This is fantastic.

I was originally going to ask if we could somehow filter for sectioned/clipped objects for snaps, but now that we can consistently omit occluded objects, this is even better.

Thanks again!

Hi again @enric,

Snaps in details for sections and elevations now appear to be broken. I can’t seem to figure out how to get a snap going in any elevations or sections. Any idea what’s up?


1 Like

Hi @Clayton_Muhleman,

You are right. A typo in my last code commit breaks snap in viewports with an active section.

Here is a new version with this problem fixed:

Note that the snap on section lines does not work for VisualARQ sections. It only works for level cut planes.



Hello again, @enric,

Getting stranger.

After install, the problem briefly appeared solved, but now snaps seems to be working only intermittently. Snaps are now working perfectly on some plans but not at all on others, and appear broken on all sections and elevations. So, two steps forward and one step back.

If you’d like me to zip a model over to you for inspection, just say the word.

Hi @Clayton_Muhleman,

Yes please, send me the model to and I’ll take a look.


Hi @Clayton_Muhleman,

I have tested my fix with your file, and you’re right, snap stopped working in some details. I’ve fixed this issue and I tested it with many document and seems to work fine.

Here is the download link:

Please, let me know if it works.



1 Like

HI @enric,

Confirmed, looks like that fixed it. Snaps are working great in plan and “good enough” in section. Although, it’d be fantastic to be able to select cut objects in section, we can make due to now.

Thanks again for your help!

Hello, I am a little confused about what is now the official recommended download for productive use.

  • On the official website I get a download without version information (VisualARQ2-Rhino7.msi). The file was apparently created on 30 May, so I assume it is v 2.13.1. because this is also the date of your initial post in this threat.

  • On the official website in the changelog v. 2.13. is listed as the latest version. (What's New - VisualARQ) Only here in this forum is v. 2.13.1 listed?

  • The bugfixes discussed in this thread and the resulting installer from 19 June is not available anywhere else and official? btw: the download link does not work for me? (leads to an XML page with AccessDenied)

thx, Matthias

1 Like

Hi @Matthias_Eder

  • The last official version released is the 2.13.1
  • The “What’s new” page is not updated with the 2.13.1 changes. Excuse us for that. We will update it asap. We usually announce the latest changes on Discourse and update the website later on, but sometimes it takes longer.
  • We have published internal 2.13.2 versions with some fixes. But these links are temporary since we built newer internal versions constantly. This is the most recent built if you need it:

We will release VisualARQ 2.13.2 some of these days.


Visual ARQ updates aren’t automatic are they?

No, they aren’t. We enable a notification when a new official update is published, but users need to download and install it manually.

1 Like

thank you for that information

Please, one thing about stairs is that when the stairs are above each other the numbers get mixed in the plan.

Eg: numbers of 2° floor stairs get in the same plan that the numbers from the 1° floor