Visual arq slow performance

Hello. I am a student who uses Revit a lot but in the last 6 months I bought a rhino educational version and I am very exited about its modelling capabilities.
The problem with rhino is drawing production, as make 2d always make mistakes.
So I tried the visual arq extension to check if I can produce better drawings from the model with this.
It seems to work very well in plan views. In 3d views, orthographic and perspective, the vector output print produce mistakes.
Then I tried to create va objects first in rhino 7. The performance is unacceptable. In rhino 6 it works much better but also there is a noticeable lag in each click. I understand this has to do with boolean operations but I used Revit to work much faster.

I have an amd rysen 9 3900x 12core processor with 64 gb of ram and a gtx 1070 graphic card

Hi @ar00302,

Which mistakes are you getting? could you share some examples (along with the 3dm file) so we can see if they can be improved?

The slow performance shown in the video is not normal. There must be some other plugin or other reason interfering with VisualARQ. What VisualARQ version do you have? what other plugins do you have installed? Try to disable all plugins that do not ship with Rhino (except “VisualARQ” and “Tibidabo”), restart Rhino and check if you get the same performance.

@fsalla do you have a mail to send you a model that dos not produce a good vector output print?

@fsalla
Here is a pdf print with visualarq hidden style
AgStefanos_va_vector.pdf (189.9 KB)

And another video with va performance and only va enabled.

and the system info report
system.txt (2.6 KB)

visualarq@asuni.com

Hi @ar00302, I don’t know why you are getting such a slow performance. I can’t reproduce it and it’s the first time I see it. Does that happen with other display modes? (for example, try it with “Wireframe”).
I can only think about a GH add-on that is causing this. Can you try the following test? Disable GH, restart Rhino, and see if the slow performance persists.

PD: the errors with the pdf are caused by a bug in the VA 2.10.0 version, that is fixed in a new 2.10.1 update. We will publish it this week, but I’ve sent you an internal version of it.

hi @fsalla
I install the new version. I disable grasshopper.
Same behavior. I also tried different display modes. Still same behavior.
Maybe is something with rhino. I have a clean install of rhino 7 on this pc. Sometimes clean installs have bugs that do not appear when you update an older version and vise versa. But my pc is really powerful.

Also about vector printing. The hatch problem solved, but many lines especially in areas where exist too many, or in small portions like railings and shutters have many mistakes.
It would be useful if can add a drawing creation command as you have for plan and section views. I have written in another post that rhino make 2d always produce mistakes for me.

Hi @ar00302 good news: we have indetified the cause of that slow performance (it has to do with how VA handles multithreaded code). It seems the code is slow (very slow) on AMD processors with the Zen 2 architecture. We have fixed this in the upcoming VisualARQ 2.11 version. I’ll let you know when it is out.

Good news. I am waiting.
For now, I have disabled it from my rhino because I think it causes many problems to the overall performance.

Thank you

Hi Francesc,
I am having similar slow performance issues but I have an NVIDIA GPU. Is the bug fix in version 2.11 likely to help me? When do you expect it to release if so?

I only started using VisualArq a few weeks ago, but things have gotten progressively worse as my files become more developed. I think the biggest decline happened after adding stairs. I don’t have very many other plug-ins, but I tried disabling grasshopper and the problem persisted. If I disable VA, however, everything speeds back up, so it is definitely related to VA.

I’m also a student and I started using VisualArq for my final project this semester. I’m too deep into it to turn back now, but my model is barely usable at this point. We just have 2 weeks left in the semester and I’m getting worried. Any help you can offer would be VERY appreciated!

System info is below. I’m also happy to share my file with you if it helps.

Rhino 6 SR34 2021-2-3 (Rhino 6, 6.34.21034.07001, Git hash:master @ 2fec8130f097ca52a8bc9f334c3ed4a5921c5e30)
License type: Educational, build 2021-02-03
License details: Stand-Alone

Windows 10.0.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: RAES-XPS

Computer platform: LAPTOP - Plugged in [89% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 10-28-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port #1
Primary OpenGL: NVIDIA GeForce GTX 1650 (NVidia) Memory: 4GB, Driver date: 3-25-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 465.89
> Integrated acclerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-25-2021
Driver Version: 27.21.14.6589
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.12.17.906\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.34.21034.7001
C:\Users\rcpat\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino6.Plugin” 0.0.20335.757
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.34.21034.7001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Users\rcpat\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2019.7.29.584\SectionTools.rhp “SectionTools”

@rtichoke do you also get the slow performance when inserting walls?
I’ll share an internal version of the 2.11 by private message to check if this problem is fixed in your case.

Thank you, Francesc! I installed the update a few hours ago and it definitely made a big difference. The lag while orbiting and zooming in my model had become intolerable, and that has drastically improved. I’m still seeing a pretty significant lag when selecting, copying, or moving VA objects (whether by dragging, or using the move or copy commands)–do you think that’s an unrelated issue?
Regardless, my model is at least functional again, so I am very grateful. Thanks for the quick reply, too!

Hi, I am experienceing similar problems but with editing walls and curtain walls syles. When I open the style tab and switch between mulions frame etc. it take unusually long to actually go from one to the other. It might be also connected with the fact that my models has quite a few of these curtain walls (what made it 770 mb big). In general those curtain walls are pain in the ass because every little twick in their properties takes abot 3 minutes to atually happen. I assume that is because they are all extended to my organic roof what makes the top mulion quite complex. Could you let me know if that sounds normal or it might be similar issue as discussed above. Regardless this is super problematic and makes the models almost impossible to work with.

Additionally I have experienced some problems with the visualarq levels and section.

When I generte a plan it has a large square in the middle altough there is nothing like that in my model.

Additionaly when I render (Vray) views that are clipped by any vsualarq sections or plans half of the geometry disappears both visualar objects and normal rhino objects. but when I turn the section clip off it works fine.

I doubt that all the issues are related so I will make a different thread but I mentioning it just in case.

Additionally, I have just identified that working in an activated VARQ Section or Plan decreases workability when compared to a normal clipping plane

Hi @mijalskid17 ,

We have fixed this slow behavior in the upcoming VisualARQ 2.11 version.

3 minutes it’s a lot! But depending on the complexity of the object where you extend the curtain walls, and the size of it, it could happen. Can you share a copy of that model so we can test if this performance can be improved? (you can send it to visualarq@asuni.com or attach it here)
In any case, this issue is totally different than the previous one.

If you explode the organic roof, and update the plan view (vaUpdate, the weird square goes away. Anyway, we will check what’s going on, so you don’t need to explode anything in this process.

This could be moved to a different Topic. We may require a copy of your model, and know which Rhino, VRay and VisualARQ versions you have, in order to reproduce it. In any case, try to run the render from the Rhino render button.

We have improved this considerabiliy in VisualARQ 2.11. I’ll send you an internal version through PM so you can check it out.

Wall.3dm (1.5 MB) Regarding the curtain wall. Try to extend it to the roof and you may encouter the issue. Extending took about 5 minuts for me. A workaround was to delet window frame and mulions and offset secondary structure which then looks like mullions and frame. Problem is that I dont have the top frame when I extend it and must model it manually.

Regards,
Daniel

Hi Daniel,
Thanks for the file. I can see the complexity of the geometry and I’d dare to say the timing to extend the curtain wall to it is “normal” in that case. (It actually takes longer on my PC). However, we will see if this can be improved.