Viewport doesn't gain focus by zooming


#1

Am I losing my mind, or is it new behavior that when I zoom in a viewport, it doesn’t get focus? When I click anywhere in a viewport, that viewport is highlighted and active, but zooming in another vieport no longer gives that viewport focus. It’s driving me nuts because standard behavior for me is to zoom into a part then move it with nudge keys… but often another viewport is active making me nudge in the wrong direction. So… I want that old behavior back!


(Wim Dekeyser) #2

Sorry about that - must be the former :wink: No such behavior around here…


(Brian James) #3

I don’t see this here either Heath. Are you maybe using a 3D connexion device? Any different without it if so?


(Pascal Golay) #4

Hi Heath- this is with no command running, correct? I believe this is standard- V4 is the same - that is, one VP is active and moving the mouse to another without clicking in it allows you to zoom (mouse wheel) in that second vp without changing the active viewport.

So I have to differ with Wim on this one, if I understand things - you are not losing your mind, or at least not on the evidence of this question, and it is not new behavior…

-Pascal


(Wim Dekeyser) #5

No way - it’s either Heath or me…

  • 4 viewports - perspective is active.
  • Move mouse across to the next viewport (in my case Top).
  • Do not click in that viewport
  • Use MMB to zoom in/out.
  • Top view is active (both the color in the viewport title and the properties tell me that much).

#6

Here (V5, V6, no V4 to test) moving the mouse cursor over another viewport without clicking does not activate it - but, as soon as I roll the mousewheel, it does activate it, so it zooms in the viewport the mouse cursor is currently in.

–Mitch


(Pascal Golay) #7

Nay! http://screencast.com/t/pW5m7niUqT Y’all do not see this?

What up with this discrepancy? V4 does the same thing here.

-Pascal


#8

Nope - this is what I see… Note I did not click in any of the viewports, just rolled the mousewheel.


(Chris Kuether ) #9

Mine works like Mitch’s, not Pascals.
Rh5R12, 32bit, normal wheel mouse.


(Pascal Golay) #10

Hmm- I have tried a couple of mices and they both do the same thing. Light touch I guess. Let me see what I can find out- thanks for the feedback, all…

Can you try Rhino in Safe Mode and see if that behavior changes? Thanks.

-Pascal


(John Brock) #11

In Options > View; Pan section, is the option checked for "Auto adjust camera target after Pan and Zoom?


#12

Yes.


(Chris Kuether ) #13

In mine, it is set to ‘autoadjust camera after pan & zoom’


(Chris Kuether ) #14

but unchecking that box makes no difference.


(John Brock) #15

Mine works like Mitch’s too, including V4.
Mouse over does not change to that viewport unless a command is running.
Moving the mouse wheel instantly changes focus to the viewport the pointer is over without clicking.

The ONLY exception to this a a floating viewport.
The new floater can be current and I can wheel zoom another viewport without it changing focus.


(Pascal Golay) #16

Scott’s works the right way. I mean, like mine…

-Pascal


#17

I just recently updated to Win10, is that a factor?


#18

Seems to me if I DO something in a window (including zooming), that window should get focus?


(Pascal Golay) #19

Yeah, I honestly do not know what is the designed behavior - I could make a case for each. I’ll see what I can find out.

-Pascal


#20

Ok, back on my other computer and I’ll confirm this: the behavior is different on the SAME version of rhino on different versions of windows. On Win7, it works as I have always experienced it: zooming in a viewport puts the focus on that viewport. In Win10, it does not, which I find problematic. If I can kick in my own preference here, it would be as I always remembered it: zooming in a viewport gives that viewport focus. Thanks…