Zoom in details

One that keeps bugging me…

When using the MMB (scroll wheel) to zoom into the scene in a detail on a layout, the scene is panned, not zoomed. Is this intended behavior?

select the object you want to zoom and press zoom selected

Thanks for your answer!
It doesn’t answer my question, though :wink:

I use zoom extents and zoom selected all the time and have trimmed its settings so that they work fine in the modeling environment. When using this in a detail, the margin to the borders of the detail are too big. I could tweak the settings so that it works perfectly for details but I then would be unhappy in modeling space. My mouse wheel is at 0.999 for precision and could use that in details.

So, again, is panning the intended behavior?

Hoi Wim,
Maybe I don’t understand the issue you describing but here it works like this:

  1. I double click a detail to make it active
  2. I make sure the detail is not locked
  3. If I scroll with the cursor on top of the detail it zooms in/out…

This is what I expect.
But maybe you talk about something else?

gr, Tobias

Behavior on my systems: As soon as the mouse wheel is moved the viewport the cursor is in becomes the active viewport and the viewport zooms. Zooming is about the location of the cursor.

That’s right, David. But that is in modeling space. I’m talking about Layout space.

Hoi Tobias,

  1. Make sure the detail is unlocked
  2. Double Click inside the detail to ‘open’ it.
  3. Scroll with middle mouse wheel pans diagonally upper left to lower right corner.

I was expecting the behavior you are getting. Weird and no wonder nobody has asked about this before. But it works fine in modeling space so I’m lost… :confused:

Yea… that’s pretty weird. Especially if it works fine in model space.
Hope the bigger brains have an idea.

gr, Tobias

Not doing that here… http://screencast.com/t/7w78wsv208 What am I missing?


Just an idea… have you tried to set the detail to something standard (ie Top, Front, etc)?
I’m asking this because your “zoom” pans diagonally… :confused:

I’ll have to try to record this somehow sometime. (screencast is blocked from where I’m sitting).

The detail is set to the standard Top view.

But I’ve now tried it on another PC, running Serengeti and the exact same thing happens there. It’s been doing this as long as there have been layouts in Rhino.

Does Ctrl - RMB zoom work?

Just checked behavior in layout space which I rarely use. RMB for pan, mouse wheel for zoom. Same as in model space. The drawing does “pan” when “zooming” if the cursor is not over the center of the drawing since it zooms at the cursor location.

I see this when using 0.999 for my zoom scale factor. If it isn’t so close to 1 (say 0.9 which I usually use), it seems to work as expected over here. The sliding / panning seems to be related to the typical zoom behavior where Rhino zooms into the mouse position, but because the zoom factor is so small, it doesn’t appear to be zooming at all. I guess if you want to keep your 0.999 for model space, a work around until someone looks at this could be to use Ctrl + RMB in an active detail in layout space.


1 Like

That’s it! Thanks, Sam!
At 0.994 it works as it should and at 0.995 one way zooms and the other way pans.

I find the step to be too big at .994; I use zoom selected/extent and Ctrl+RMB to do all of my regular zooming.
My work-around for the time being will be to zoom selected and from there tweak the scale setting in the properties panel of the detail.