-viewcapturetofile won't consistently render

I’m finding the “-viewcapturetofile” command does not consistently render raytraced images in Rhino7 - the same was fine in Rhino6. Some images are rendering, and all ‘arctic’ images render, but ‘raytraced’ images are hit-or-miss.
After it cycles through a rendering, the result is an all white image.
Attached are two views, one arctic the other raytraced. The objects are simple geometries resulting in a file that’s 181kb.

Any thoughts on what needs to happen to get consistent results?

I do daily multiple view captures with those commands. To be able to figure out what may be the problem it’d be useful if you ran the Rhino command _SystemInfo and pasted the resulting text in a reply here.

Thanks Nathan - Here’s the result from the _SystemInfo command:

Rhino 7 SR2 2021-1-21 (Rhino 7, 7.2.21021.07001, Git hash:master @ 96ff97351fbdf5d2acdeaf781aea1577f2ff60f7)
License type: Commercial, build 2021-01-21
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: Intel® UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 9-5-2020 (M-D-Y). OpenGL Ver: 4.6.0 - Build
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor attached to adapter port #0
- Windows Main Display attached to adapter port #1

Secondary graphics devices.
NVIDIA Quadro P1000 (NVidia) Memory: 4GB, Driver date: 12-11-2020 (M-D-Y).
> Accelerated graphics device with 4 adapter port(s)
- There are no monitors attached to this device!
Citrix Indirect Display Adapter (Citrix Systems Inc.) Memory: 0MB, Driver date: 1-23-2019 (M-D-Y).
> External USB display device with 8 adapter port(s)
- There are no monitors attached to this device!

Desktop is using the slower, less reliable integrated graphics device and probably needs a configuration change.

There are 2 monitors detected, but none of them are connected to any of the accelerated graphics video ports.

  • Recommended: Unplug one of the monitors and plug it into one of the video ports on this device:
    [NVIDIA Quadro P1000]
    …and then using Windows’ Display Settings, make that monitor the “Main Display”.
  • Any hardware configuration or cabling changes you make will require that you restart Rhino.

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel
Render version: 4.6
Shading Language: 4.60 - Build
Driver Date: 9-5-2020
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\import_ACAD.rhp “AutoCAD file import: import_ACAD”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

(my monitors are old and and only one has a DV out which is in a desktop DV port)

Have you tried the recommendation from the system info you posted?

Yes - the monitors are correctly attached despite Rhino’s assessment. I have two, both attached via DVI port to the primary display ports identified on the CPU.

Still getting inconsistent results…

Note that all other display modes do successfully output via -viewcapturetofile. Just not raytraced.