-ViewCaptureToFile Command fails with altered options


#1

Hi,
-ViewCaptureToFile Command fails to save the screenshot if any of the options (size, scale, transparent background, etc) is modified.

Best regards,
Bastian


Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-08-27 (523)
OS X version: Version 10.9.5 (Build 13F34)

Plug-ins
/Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient
/Users/Goecke/Library/ColorPickers/SkalaColor.colorPicker/Contents/MacOS/SkalaColor

Third party kernel extensions
com.Logitech.Control Center.HID Driver (3.9.1)
com.Logitech.Unifying.HID Driver (1.3.1)

Hardware information

Computer hardware
Hardware model: MacPro5,1
Processor: Intel Xeon CPU W3680 @ 3.33GHz
Memory: 12 GB
Architecture: Intel 64 bit

Video hardware
Graphics: ATI Radeon HD 5870 1024 MB
Memory: 1024 MB
Screen size: 1920 x 1200
Displays: SX2461W

USB devices
Logitech: USB Receiver
Wacom Co.,Ltd.: Intuos5 touch M
Apple, Inc: Apple Keyboard
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-1.24.38
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: Nichts
Anisotropic filtering: Nichts


(Brian James) #2

I just tested this here using the latest 5A527 build of Mac Rhino released yesterday and it’s working with any changes I make. Can you test with the latest build please? You’ll need to manually download it.

If you still see the image not being saved, please provide a file and screenshot of the settings you’re using.


#3

you are right.
I forgot to mention that I was using a background image in that viewport. With placed background image via viewport preferences the command fails like reported.

Thanks!


(Brian James) #4

Thanks for the extra info. Filed as http://mcneel.myjetbrains.com/youtrack/issue/MR-931

This happens with the dashed version of the command and with Wallpaper but doesn’t with BackgroundBitmap if that helps in the meantime.

We also have an open item dealing with display mode background images not showing up here… http://mcneel.myjetbrains.com/youtrack/issue/MR-760