ViewCapturetoFile failing on high res


I’m having trouble with exporting a raster view of my model that isn’t super low quality. The lower res images export fine, but anything above 1920 x 1080 fails. That is to say, rhino says it has exported the image successfully, but the actual image I get is split into four sections and cropped (please see attached images for the lower res and the failed higher res).

I tried to do a lot of different resolutions, as well as using the Print command to get a pdf, but it’s always the same result.

Please let me know if anyone knows how to fix this.

Thanks a million,


Hi Valeria -
Please run the Rhino SystemInfo command and copy-paste the result here.

Hi Wim,

Please see below.

Rhino 7 SR15 2022-2-8 (Rhino 7, 7.15.22039.13002, Git hash:master @ 2833e18992fc4b5cf99bb29c4d8e8add4f02074d)
License type: Educational, build 2022-02-08
License details: Cloud Zoo

Apple macOS Version 10.14.6 (Build 18G103) (Physical RAM: 8Gb)
Mac Model Identifier: MacBookPro10,2
Language: en-FR (MacOS default)

Intel HD Graphics 4000 OpenGL Engine (OpenGL ver:4.1 INTEL-12.10.12)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1536 MB
Graphics: Intel HD Graphics 4000
Displays: Color LCD (227dpi 2x)

Graphics processors
Intel HD Graphics 4000 (1536 MB)
Color LCD (1280 x 800)

USB devices
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)
TOSHIBA: External USB 3.0
PixArt: HP 1000 USB Optical Mouse

Bluetooth devices

Third party kernel extensions

Third party plugins

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino “RhinoCycles” 7.15.22039.13002
/Applications/Rhino “Snapshots” 7.15.22039.1002
/Applications/Rhino “Grasshopper” 7.15.22039.13002
/Applications/Rhino “PanelingTools” 7.15.22039.1002
/Applications/Rhino “AnimationTools” 7.15.22039.1002
/Applications/Rhino “Commands” 7.15.22039.13002
/Applications/Rhino “Renderer Development Kit” 7.15.22039.1002
/Applications/Rhino “RDK_EtoUI” 7.15.22039.13002
/Applications/Rhino “Displacement” 7.15.22039.1002
/Applications/Rhino “AutoCAD file export : export_ACAD” 7.15.22039.1002
/Applications/Rhino “Rhino Render” 7.15.22039.13002
/Applications/Rhino “IronPython” 7.15.22039.13002
/Applications/Rhino “Legacy Rhino Render” 7.15.22039.1002

I thought I had reported my problems with this before. If I set Resolution to CUSTOM and SCALE=2 (for example) I just get the background in an otherwise empty image file.