-ViewCaptureToFile doesnt work properly


#1

Hello,

-ViewCaptureToFile on mac doesnt open the expected box. 18 PM

as opposed to -ViewCaptureToClipboard which opens


(Dan Belcher) #2

Hi @yousef.k

This command - in Rhino 5 - causes so much confusion. (We’ve really tuned it up in Rhino 6 though!) You actually have to Browse and tell the command where to save first before you get options to set the resolution. I know, pretty dumb. Sorry about this.


#3

Thanks Dan


#4

hi @dan , i just tried this again on a mac it does not work as you say. i think it actually is a bug.


(Dan Belcher) #5

Strange. It is working for me here in the latest RhinoWIP (5E397w).

Here are the steps I’m taking to reproduce this

  1. Start the _-ViewCaptureToFile command.
  2. Click the Browse button.
  3. Enter a valid filename and path (I saved mine on the Desktop).
  4. Click Export.

Expected Behavior: The View Capture Settings dialog appears.
Actual Behavior: The View Capture Settings dialog appears.

What are we doing differently?


#6

Maybe cause I’m using Rhinoceros version: 5.3.2 (5D197).


(Dan Belcher) #7

This is also working as expected for me in Rhino 5.3.2 (5E197).


#8

That’s strange. I’ve uploaded a video for you to see. Maybe i’m doing something wrong?


(Dan Belcher) #9

Please type -ViewCaptureToFile (note the leading -).

Again, the UI for this is really poor. See above.


#10

I see. silly mistake from my part. Thank you for the help Dan.


(Dan Belcher) #11

No problem! Glad there’s no bug there - other than the rather undiscoverable and weird UI. It’s much better in Rhino 6 already…but we’ll have to wait for that.


#12

How long…? Sorry, couldn’t resist :wink: Peace! :slight_smile:

Philip


(Dan Belcher) #13

I estimate about kolmesataakolmekymmentäkolme (base 12) hours. Give or take.


#14

:+1: