ViewCapture not working

Trying to use ViewCapture in v8 – it’s significantly slower than in v7, but more importantly, it does not accurately export what’s in the viewport.

Here’s an a/b comparison. Viewport:

exported file:

Note also that it’s not correctly drawing all the meshes (see the 3rd couch pillow), but that’d be workable if it didn’t also suddenly impose mesh colors – this display mode is based on “technical” and should override all material settings with a single (white) material.

It also is doing this imposition inconsistently – if you look at the faraway chairs, you’ll see they’re half and half colored / monochrome.

Sharing some more examples, since ViewCapture still doesn’t work consistently.

FWIW, it’s a super useful feature for generating shareable, nice-looking images without going through a whole rendering process.

This display mode is based on “mono,” the only difference being the lines are all black and thinner.

Here’s what the viewport looks like – so far so good:

here are my settings:

And here's the exported image:

The top-left quarter of the image is rendered with what looks like a different light source or something? The

Anyone come across this / any ideas how to fix?

Hi Sam - thanks, I’ll check this.
@samface - can you please post the output from the SystemInfo command in Rhino?


Sure thing – sorry, just saw this @pascal :
systeminfo.txt (12.3 KB)

@pascal I have the same Issues with View Capture. That’s why I stopped using V8 for now. I usually use the Arctic Mode with rendered materials for the first visualisations. Works fine in V7 and not at all in V8.

System_Info_Veit.txt (4.7 KB)

Hi Veit - can you please also run SystemInfo in Rhino and copy/paste the results here?
Never mind. I see it.


Veit, are you also trying to capture images at higher than screen resolution?


Guilty! :slight_smile:
To my defense, I worked before on Windows with Rhino and it was never a problem. Thanks for pointing that out!

Hi Veit - you absulutely should be able to capture at high resolution, I was asking for trouble-shooting purposes, not to suggest you are doing something wrong. That said, so far, I cannot reproduce the problem. If you or @samface can post a file that shows the problem, or send to, with a link back to this topic in your comments, that might help pin down the problem.


Hi Pascal, here I run in the same Issue when I export it with high resolution like in the Screenshot.

240220_Veit_R8_test.3dm (3.1 MB)

File is attached :wink:

@pascal here’s an example from me too, figured the more the merrier. There’s a named view called “test” that I used for the view capture.

test.3dm (6.6 MB)

Thanks to you both - so far I only see the problem in Viet’s file but I am still poking at it.
RH-80533 ViewCaptureToFIle: high resolution error


@pascal this probably doesn’t help you, but I’ve found the problem to be fairly tricky to reproduce consistently – sometimes I can fix it by moving the view slightly, and sometimes moving the view seems to cause the bug.

I see, thanks, I’ll keep at it.