View clipping the model

Hello,
This is recurrent and I once knew how to solve this but I don’t seem to find any reference to it.
When I zoom in a perspective view, at a certain point the model starts to be clipped. Initially it was only when I zoomed quite a bit but it has been degrading and now a saved view that I have used several times this afternoon viewing the whole building now has the building clipped 20 meters away from the camera viewpoint.
Previously the issue seemed mitigated by placing the target away from the camera, but in this case the view is saved since two days ago and now it does not work.

Any ideas? N

Hello - there are a couple of things you can try - in a perspective view, if you need to zoom in really close, things are more reliable if you can change to a parallel projection - does that look better? . You may also want to set the camera target using Zoom>Target rather than the the default Zoo to a window. I don’t know that that will help the clipping but it makes the general view manipulation more predictable.

-Pascal

Hi Pascal,
yes, I normally get over it by placing the target further than it is or zoom select to a bunch of objects in the area I want to work in. It is an annoying bug but you can get over it.
The strange thing is that it happens in some files and other it does not.
In this particular case, I have saved a view that worked just fine and which I want to keep because I am comparing options from that point of view. Also it is not clipping close geometry. The building is 15 meters away and the clipping plane about 40 meters away (so I only start seeing the building after 40 meters). No matter which viewing mode (rendered, ghosted) I choose, it looks the same - clipped.
Again, the strange thing is that the view was working and then it did not without any apparent reason.
N

So here is a couple of strange things.

  1. I have noticed that if turn the ground plane on and off, the clipping changes or disappears. In the case of that specific view it moves about 15 meters towards the camera.
  2. To understand how far exactly the camera was from the geometry, I made the camera visible. In doing so I saw the camera position, the target and associated plane and a dashed plane between the two… about the same position where the clipping happened.

Indeed turning on and off the ground plane, that dashed plane came toggled between the two clipping positions.
There is a control point associated with this plane but when I try to move it the whole camera and target move with it. Any idea how to control this point? (and how/why it changes when toggling ground plane? and how/why it may have changed in a saved view?)
N

Hi @pascal,
This continues to get stranger.
When I zoom extended I found that I had an object in a galaxy far away. I deleted it and -viewrestore’d my 003 view on standard perspective viewport and it looked alright. I turned -camera to show and went to the standard 4 tiled viewports… to my surprise the top-right viewport where the 003 saved view originally was still showing the clipping plane, while the bottom-right viewport where I had now restored the 003 view was showing it ok. The camera icon (on the top view) showed the near clipping plane as it should be (i.e. the bottom-right viewport). I tried to restore the 003 view on the top-right viewport, but it did not change. I then restored the 003 view on the bottom-left viewport and it kept the clipping plane.
180801%20same%20view%20diffResult

Then with the top-right viewport selected, I used -Camera and Toggle’d and all viewports looked the same, without the clipping plane, but when I toggle’d the -Camera again, the top-right viewport looked ok, but the other reverted to the clipping plane…
180801%20same%20view%20diffResult2

I have no idea what is going on here but there’s something strange…

Hello - one thing to try is to close, one by one, all the viewports (Viewport menu> Close) and then run 4View.

Does that do anything?

-Pascal

@pascal
I have closed all but the top, with the same result
I have closed all but the good one, with the same result
I have -saveview as 004, and restored 004 in the other 2 with the same result

Hello - can you send us the model? (www.rhino3d.com/upload att’n Pascal)

thanks,

-Pascal

@pascal
Done. I selected a simplified geometry and the problem persisted on this end.
n

Hi n - thanks - it looks fine here of course… the camera clipping looks as expected

image

I’m not sure what to suggest…

-Pascal

Really? even in the 4 views?
I’m in rhino 5. Try to replicate.
When I open the file it looks like this. check also that groundplane is on.
180808%20open%20file

after toggling camera it looks like this. Note that the near clipping plane looks ok also (and even further from the objects than yours). Nevertheless, two viewports are clipped.
180808%20Camera%20t

when I toggle the camera on other viewport this is what it looks like
180808%20Camera%20t2

When I turn groundplane off, all views are ok and the near clipping plane seems close to yours.
180808%20Groundplane%20off

Among the strange things, the strangest is that there’s one viewport that look ok while the others don’t.
N

Pascal: it looks fine here… the camera clipping looks as expected

@pascal,
further to my other reply, I would still argue that your result is not as expected. That clipping is about 10 meters from the camera. I can not be expected that geometry is only visible after 10 meters.
I have now also found out that the clipping lane of the initial view is influencing other perspective views - i.e. a second view close to the initial one is not influenced by its own clipping plane but by the clipping plane of the active Camera.

I realize that turning the camera off resolves some of the problems but note that I have turned the camera on in an attempt to understand a clipping plane that was already occurring .
N

Hi N - I’m not sure I follow - the clipping is on either side of the objects in the scene so everything is in view. There is nothing that the camera should see that it cannot… But in any case, here, monkeying with the ground plane or toggling the camera seems to make no difference in the display. So I’m for blaming the video card/driver at the moment - what does SystemInfo report, can you run that command in Rhino and paste the output here?

-Pascal

@pascal
SystemInfo command does not work on my end. Any idea why?
N

SystemInfo is a new command in Rhino 6. Is that where you are trying to run the command?

@wim @pascal
I’m on Rhino 5

Hi Pascal,
I’ve updated to Rhino 6 and still run into this problem. It is always connected to the ground plane being on or off.
In this version, it also happens when using displayMode Arctic (with or without groundplane).
It may be related to my machine but it still strange that groundplane triggers this.
n

Hi - could you now please run the Rhino 6 SystemInfo command and post the result here?
Thanks!
w

Hi Wim,
Thanks for your reply.

Rhino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: Commercial, build 2019-02-27
License details: Cloud Zoo. In use by: nsgma ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: XX

Non-hybrid graphics.
Primary display and OpenGL: Intel® Iris® Graphics 540 (Intel) Memory: 1GB, Driver date: 10-11-2018 (M-D-Y). OpenGL Ver: 4.5.0 - Build 24.20.100.6299

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.5
Shading Language: 4.50 - Build 24.20.100.6299
Driver Date: 10-11-2018
Driver Version: 24.20.100.6299
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

1 Like

I’ve been having the same issue for about a year using Rhino 6 for Mac. Especially with a large file, the camera can clip a significant amount of my objects in close view, enough that I cannot zoom in to get a closeup of a polysurface vertex.

2 Likes