Unwanted viewport clipping

I’ve been getting this on a few of my models lately . When the camera gets too close to an object. the object appears clipped even though there is no clipping plane.
Is there any way to fix this?

Hi Andrew - please run the Rhino SystemInfo command and copy-paste the result here.
Do you see this issue with any display mode?
-wim

Hi Wim,
Yes it’s happening on all display modes. Arctic seems to clip at a different spot to the others. Also the number of objects displaying on the screen affects the clipping distance.


Rhino 7 SR0 2020-6-2 (Public Build, 7.0.20154.14355, Git hash:master @ e6c4f6454b96fbf94100810710d49300518d1a88)
License type: Educational, build 2020-06-02
License details: Cloud Zoo
Expires on: 2020-07-17

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce RTX 2080 Ti (NVidia) Memory: 11GB, Driver date: 1-29-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 442.19

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-29-2020
Driver Version: 26.21.14.4219
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 11 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Bongo 2.0 (64-bit)\Rhino6\Bongo.20.rhp “Bongo 2.0”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Bongo 2.0 (64-bit)\BongoUI.20.v60.rhp “BongoUI20v60”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7 WIP\Plug-ins\Commands.rhp “Commands” 7.0.20154.14355
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7 WIP\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20154.14355
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20154.14355
C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20154.14355
C:\Program Files\Rhino 7 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20154.14355
C:\Program Files\Rhino 7 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7 WIP\Plug-ins\Displacement.rhp “Displacement”

I also see this when there is an object a long way off in the distance.

  1. Show all 4 views
  2. Zoom extents in all 4 views

If the model stays centered in all 4 views you are good.

If the model disappears in any of the 4 views then there is a set of objects way in the distance.

1.Select the building

  1. Use “Invert” to reverse the selection to find the objects in the distance.
  2. Hit delete
  3. Do zoom extents in all 4 again to make sure the problem is fixed.

Another problem can be that the building is a long long way from 0,0,0. It would have to be many miles away. Moving to 0,0,0 can help there.

Hi Scott,

Zoom Extents centers on my building so that’s good. Select/Invert doesn’t show up any objects other than the building.

The building is 7.8km (4.8 miles) away from the origin so that might have something to do with it.
I tried moving the building to the origin but I still had the clipping issues. I’ve saved a whole bunch of cameras for a Bongo animation at the original position, so maybe those saved elements so far from the origin are still causing the issue?

This model did come from Revit so that could be the issue with this file, however, I was working on another v7 file that I built from scratch at the origin. It was a 100m diameter model, and I was getting clipping issues with that.

I reported something similar also earlier this week. Unsure of the YT number though.

I have been reporting this as well several times before, here is the latest one that we even tried to come up with scripting solution to the problem with @Holo.


But ultimately never got any real support or help with the code from McNeel’s team…

Seems like it is a very common issue and lot of users run into this - so far it has been ignored and it is a major display problem. Can it get some interest finally and get addressed please? Is there a YT item for anything related to the view clipping planes not catching up with the model? It would save everyone a lot of frustration and time typing here and answering the same question over and over again.

–jarek

My case was very strange in that I had clipping of about 25% of the viewport of the first 3DFace I laid down - it was an empty doc. And this was at a few scales too.

Sample models work wonders in this case. Everyone with the problem, send in the models and reference this thread.

If the models are large use this: https://www.rhino3d.com/upload

There are many many iisues that can cause this. Without examples we are just guessing.

Hi Scott,

I uploaded the model for the specific case I linked above on January 10th. Let me know if you guys still have it or need a re-upload. Yes it takes time to prepare samples for you and often is an effort that is worth it but in this particular case I have prepared models, did a lot of testing and trying, all homework for you guys, with the thread abandoned. Not very encouraging to keep doing so.

Thanks,

–jarek

Sure, you mean LargeScene_ClipProblem.3dm. Yes, we have it and thank you very much for the model

The model from @Andrew shows a different way. it would be great to have that model too.

1 Like

Actually, the simple sample file is on Discourse, here:

Hi Scott,
I just sent it to you via email.

One thing to try (sometimes helps, but not in my case) us to run ShrinkTrimmedSurfaces on your entire model. Sometimes on imported models or ones where you used MergeFaces command the untrimmed surfaces behind the trimmed ones are huge and can cause the clipping.

1 Like

Thanks Andrew. Is there a specific view you are seeing the problem?

I can tell that the building being 4.2 million units from 0,0,0 is not helping at all. I would move it to 0,0,0 and then run ClearAll meshes. Video cards many times hold meshes as single precision, so there are some limits on how detailed their clipping can get. Although on my video card I have not had to move it yet.

Also the fact it is one large block does not help clipping. I exploded the largest two blocks. The whole building, then the vertical panels. Zoomed extents and got some nice shaded images in and around the escalators. But, if there is specific view i need to check out I can.

I notice the block exploding and zoom extents after that was important to keep the display clipping under control. What happens in your case?

Hi Scott,

I also have similar issues, sometimes the clipping can be solved by restarting Rhino. However, even I can see from the viewport, once I try to print it out, it never comes normally. It only happens under the rendered mode.


Yep, send it.

So far the two models have a similar pattern which we could look at. 2+ million units in size or 4 million units from the origin. But, it is not simply the large units. It is the large units combined with other factors. So, more models always helps.

Normally I try to find a workaround so that all of you can get up and running as quick as possible. Then we will also look at these thru a microscope to see if there is anything we are doing incorrectly.

Hi Scott,

Thanks for looking into this. So I exploded all my blocks, moved everything to the origin and cleared all meshes. Unfortunately I’m still getting the clipping. It’s happening anywhere I move the camera close to an object; walls, escalators, floors.

I even SelBadObjects, as I’ve found bad objects can be a cause of display issues, but there aren’t any in the scene…

Is there a specific saved named view that is causing the problem?

Yes, bad objects can produce something similar because there render mesh can be very of from those.

Just the perspective view in the bottom right viewport. It happens anywhere you move the camera close to an object.